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Before You Begin 

About Accelrys GCG (GCG) 

GCG is an integrated package of over 150 programs that allows you to 
manipulate and analyze nucleic acid and protein sequences.  Scientists from all 
over the world have collaborated to develop and refine GCG, making it a 
flexible tool with which to analyze your sequence data. 

Among its many features, GCG gives you access to: 
• Comparison.  Compare two or more sequences.  Create, edit, display, and 

analyze multiple sequence alignments. 

• Database Searching and Retrieval.  Search nucleic acid or protein sequence 
databases for sequences similar to your query sequence or sequence pattern. 

• DNA/RNA Secondary Structure.  Predict and display optimal and 
suboptimal DNA or RNA secondary structures. 

• Editing and Publication.  Enter sequences from a digitizer or a keyboard 
and edit them. 

• Evolution.  Determine and display evolutionary phylogenies from multiple 
sequence alignments. 

• Fragment Assembly.  Manage and assemble nucleotide sequence fragments 
in a sequencing project. 

• Gene Finding and Pattern Recognition.  Recognize terminators, repeats, 
protein coding regions, and other consensus patterns. 

• Mapping.  Calculate and display restriction digests and simulate RNA 
fingerprints. 

• Primer Prediction.  Predict optimal primers for PCR reactions. 

• Protein Analysis.  Identify sequence motifs in protein sequences and make 
predictions about peptide isolation. 

• Translation.  Translate nucleic acids into proteins and back translate proteins 
into nucleic acids. 
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Interfaces to GCG  

In addition to the new SeqMerge interface, GCG provides these interfaces for 
your analysis needs: 
• SeqWeb.  Provides a web interface to a core set of GCG programs.   

• SeqLab.  Based on X Windows, SeqLab provides a point-and-click multiple 
sequence editor and annotation tool with access to all GCG programs.  

• Command-Line.  Each program steps you through the required parameters it 
needs to run.  Add optional parameters to the command-line for customized 
analyses.  Scriptable command lines provide the ability to do repetitive and 
numerous analyses. 

About SeqMerge 

SeqMerge is GCG’s powerful new fragment assembly application with an X 
Windows graphical user interface.  SeqMerge allows you to intuitively assemble 
fragments in a sequencing project into contigs, or alignments of overlapping 
fragments.  From the contig, SeqMerge creates a consensus sequence 
representing the underlying sequence from which your fragments were derived. 

Using this guide 

This guide describes how you can use SeqMerge to assemble fragments in your 
sequencing projects.  It contains the following sections: 
• Getting Started.  Introduces SeqMerge and provides the background you 

need to use SeqMerge to assemble your sequencing projects. 

• SeqMerge Tutorial.  Takes you through an example sequencing project, 
highlighting the main functionality available in SeqMerge.  

• The Project Manager.  Summarizes the SeqMerge Project Manager 
Window and menu items and describes how you create, manage and 
assemble fragments in a sequencing project. 

• The Contig Editor.  Describes how you can navigate, view, and edit the 
contigs in your project from the SeqMerge Contig Editor window. 

• The Trace Viewer.  Describes how to view trace files in the SeqMerge 
Trace Viewer when editing your fragments. 

This chapter describes the conventions used in this guide; presents 
information for obtaining online help, training, and technical support; and 
lists the requirements for using SeqMerge. 
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Conventions used in this guide 

Some conventions in this guide make the text easier to read.  Becoming familiar 
with these conventions will help you extract the information you’re interested in. 

Note: This symbol indicates a helpful tip which may provide insight or might 
make your work easier. 

Text conventions 

Command-line The Courier New typeface indicates characters you should type 
when working from the command line.   

 For example: seqmerge &   

Mouse This guide assumes a three-button mouse.  If you are using a 
PC or Macintosh that has a one-button or two-button mouse, 
refer to your X server software documentation or see your 
system manager for how to define the middle and right mouse 
button. 

<Ctrl>c Keys on a keyboard appear in angled brackets < >.  For 
example, <Ctrl>c indicates you should press and hold the 
<Ctrl> key and press the letter c.   

<Return> <Return> indicates your carriage return key.  Pressing 
<Return> tells the computer to execute the command you typed 
on the command line.  On some keyboards this key is called 
Enter.  (Do not confuse the <Return> key with the <Enter> key 
on the numeric keypad on the right side of your keyboard.) 

UNIX This documentation uses “UNIX” to refer to Solaris, IRIX, 
AIX, Linux and Compaq Tru64 UNIX (formerly Digital UNIX 
and OSF/1). 

UNIX Shells GCG runs on both the C shell and Korn shell.  When system 
commands differ between the two, both commands are given, 
marked as either “csh” or “ksh.” 
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Technical support 

You can reach technical support staff by telephone, fax, or e-mail:  
 
US 
Toll Free: +1 800 756 4674 
Tel: +1 858 799 5509 
Fax: +1 858 799 5102 
E-mail: support-us@accelrys.com 

Europe 
Tel: +44 1223 228822 
UK local rate: +44 845 741 3375 
Fax: +44 1223 228501 
E-mail: support-eu@accelrys.com 

Japan 
Tel: 81 3 3578 3861 
Fax: 81 3 3578 3873 
E-mail: support-japan@accelrys.com  

When you call, you should be at your computer and be prepared to provide the 
following information, if possible: 

• Where do you use GCG, and what version are you running? (Type % 
gcgversions to display GCG banner, which lists the version you are 
using.) 

• From what operating system are you running GCG? (Type % uname.) 
• What interface are you using (command-line, SeqLab, or SeqWeb)?  
• What hardware and, if applicable, terminal emulator are you using? 
• What exactly was the command you typed and the error message returned? 
• What data were you using? If possible, supply the support staff with the data 

to replicate the problem. 
• What have you done to try to solve the problem? 

Make sure you supply the support person with your name, e-mail address/fax 
number/telephone number, and the name of your company or institution. 

SeqMerge requirements 

You can run SeqMerge from the UNIX command-line or SeqLab interfaces to 
GCG.  To use SeqMerge, you need an X Windows display such as an X 
terminal, an X server running on a microcomputer, or a workstation that runs X 
Windows.  You also need a color monitor.  For more information on GCG and 
how to configure your environment, see Appendix A, SeqMerge Interaction with 
GCG. 
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1. Getting Started 
 

Overview 

SeqMerge is an add-on to GCG  that allows you to easily perform the complex 
task of assembling your fragments into contigs, or alignments of overlapping 
fragments.   

For example, you might have used the “shotgun” approach to sequencing 
whereby you randomly cut your target DNA into small pieces and then 
sequenced fragments at random.  Many of your fragments contain the same 
sequence data as other fragments, which provides overlap between fragments.   

SeqMerge finds the regions of overlap between fragments and creates a multiple 
sequence alignment of contiguous, overlapping fragments.  Below is a sample 
contig displaying the overlapping fragments in a contig alignment?  SeqMerge 
uses the alignment to create a consensus sequence representing the underlying 
sequence from which you obtained your fragments. 

 

 

 

 

 

 

A multiple-fragment contig contains several fragments with overlapping ends, as 
in the above example.  A single-fragment contig contains only one fragment 
because it has not been determined to have overlap with other fragments.  When 
you add a fragment to a project, it is a single-fragment contig.  Once you 
assemble it with overlapping fragments, it becomes part of a multiple-fragment 
contig. 

SeqMerge lets you add fragments acquired from automated sequencers or any 
sequence file format you can use with GCG.  For example, you can add GCG 
database sequences, or sequences created by SeqEd, SeqLab, or one of GCG’s 
reformatting programs.   

Contig Alignment  

Consensus Sequence 
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Once you enter fragments into a sequencing project, you can mask (hide) vector 
and poor quality data at the ends of the fragments.  SeqMerge ignores masked 
sequence when it assembles overlapping fragments to create a contig. 

You can continually add new sequences to the project and assemble them with 
existing contigs.  As new sequence data is added, the project evolves from a 
collection of short fragments into a final contig representing the underlying 
sequence from which you obtained the fragments.  

At any time, you can display and edit the fragments within a contig or view a 
contig graph representing the overlapping regions.  And, if your fragments 
originated from ABI or SCF data files, you can view their traces. 

SeqMerge allows you to disassemble the contigs in a sequencing project and 
assemble the project from the beginning.  It keeps an archive of the sequences 
within the project, to which you can revert at any time during your analysis.   

Typical stages in an sequencing project 

Assembling fragments in a sequencing project involves the following activities.  
Each stage is described in detail in later chapters.  The tutorial in Chapter 2 uses 
a sample project to walk you through each of these stages.  

• Starting SeqMerge.  You can start SeqMerge from within SeqLab or from 
the command line.  SeqMerge will open to the SeqMerge Project Manager 
and display your last opened project.  For more information, see “Starting 
SeqMerge,” later in this chapter. 

• Creating a Sequencing Project.  SeqMerge holds your sequence data in a 
sequencing project.  For more information, see “Creating a Sequencing 
Project” in Chapter 3, Working in the Project Manager.   

• Adding Fragments to a Project.  You can continually add new sequences to 
the project and assemble them with the existing contigs.  Likewise, you can 
remove sequences from a project at any time.  For more information, see 
Chapter 3, Working in the Project Manager.   

• Finding and Masking Vector Sequences.  If any of the fragments include 
contaminating vector sequence data, you’ll want to mask the vector data so 
they don’t affect the assembly.  Use the GCG Vector database to help you 
find vector sequences.  For more information, see Chapter 4, Masking Vector 
Sequences. 

• Assembling Fragments.  You can assemble all contigs, selected ones, or 
archived sequences at any time.  For more information, see Chapter 5, 
Assembling Fragments. 
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• Viewing the Contig.  You can view sequences in a contig from the Contig 
Editor.  A contig schematic and coverage map represent each sequence in 
relation to the other sequences in the contig.  For more information, see 
“Viewing Sequences in the Contig Editor” in Chapter 6, Working in the 
Contig Editor. 

• Navigating through the Alignment.  You can use several shortcuts, which 
enable you to maneuver through the contig and view masked fragment ends, 
masked vector, and consensus sequences in your alignment.  For more 
information, see “Navigating through Contigs” in Chapter 6, Working in the 
Contig Editor. 

• Editing Contigs.  You can modify fragments in your contig when you have 
discrepancies or new information.  You can revert back to the original, 
unedited data at any time.  For more information, see Chapter 6, Working in 
the Contig Editor. 

• Exporting Contig Consensus Sequences.  You can export your contig 
consensus sequences for further analyses with other GCG programs.  For 
more information, see “Exporting Contig Consensus Sequences” in Chapter 
3, Working in the Project Manager. 

• Exiting SeqMerge.  If you started SeqMerge from the command line, when 
you exit you are returned to the directory you were in when you started 
SeqMerge.  For more information, see “Quitting SeqMerge and Logging Off” 
later in this chapter. 

Online tutorial 

The tutorial in Chapter 2 is available within this manual as well as online via 
your web browser. 

To view the tutorial from your web browser: 

1. If you do not know the location of the GenDocHTML directory, choose 
from the following: 

• From within SeqMerge, select Tutorial from the Help menu of the 
SeqMerge Project Manager window.  The help tells you where the 
Seqmerge_Guide.pdf file is located.   

• From the GCG command line, type the following command to display 
the UNIX directory with the logical name GenDocHTML: 
% name gendochtml 

2. Choose from the following: 

• If you are using Netscape, follow these steps: 
a. Select Open Page... from the File menu.  The Open Page dialog 

box appears. 
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b. Use the Choose File... option to navigate to the directory and 
select the seqmerge_tutorial.html file, or type the directory path 
and filename in the text box. 

c. Click Open.  The SeqMerge Tutorial appears. 

• If you are using Internet Explorer, follow these steps: 
a. Select Open... from the File menu.  The Open dialog box 

appears. 

b. Use the Browse option to navigate to the directory and select 
the seqmerge_tutorial.html file, or type the directory path and 
filename in the Open text box. 

c. Click Open.  The SeqMerge Tutorial appears. 

Logging on 

To use SeqMerge, you will either be: a) directly connected to the computer 
running SeqMerge, or b) connected via a network to the computer running 
SeqMerge. 

To log on to a UNIX computer: 

Note:  You must have an approved account, also called a login, from the system 
manager to use any UNIX computer.  The system manager usually sets up a user 
name, which is typically your first or last name, and lets you specify a password 
for security.  No one can access the system through your account without your 
password. 
1. Because each site is different, see your system manager for instructions on 

how to connect to the UNIX computer. 
When you are connected, you should see the Login: prompt on the screen.  
If you don’t, press <Return> until you does. 
If you are logging on using a Macintosh or PC running X server software, 
see your system manager for help. 

2. Type your user name and press <Return>.  The system displays the 
prompt Password:. 

3. Type your password and press <Return>.  For security, you will not see 
your password appear on the screen as you type.  The system welcomes you 
and logs you in. 

Note:  If you make a mistake in typing your user name or password, press 
<Delete> to delete the error or press <Return> and try again. 

When you see the operating system prompt in the left margin of your screen, the 
computer is ready for your commands. 
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Starting SeqMerge 

SeqMerge is based on the OSF/Motif™ windowing interface and runs on UNIX 
computers.  To use the interface, you need an X Windows display, such as an X 
terminal, X server software running on a personal computer, or a workstation 
that runs X Windows.  Because SeqMerge uses color to aid in sequence editing 
and analysis, you will also need a color monitor. 

Initializing the GCG environment 

Before starting SeqMerge, you must initialize the GCG environment.  
Initializing the GCG environment gives SeqMerge access to GCG databases and 
auxiliary files required for SeqMerge to run smoothly. 

To initialize the GCG environment: 

From the operating system prompt, type 

% source <Installed directory path> gcgstartup 
% gcg  

The system takes a few seconds to initialize the GCG environment and displays 
a banner similar to the following: 

 

The banner displays the version of GCG installed as well as the bibliographic 
reference to cite if you use the package in your publishable research.  (Because 
the banner changes with each update to the available databases, your banner may 
look slightly different than the one above.)  

Starting SeqMerge 

You can start SeqMerge from the command-line or the SeqLab interface to 
GCG.  
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Starting SeqMerge from the command line 

To start SeqMerge from the command line: 

At the operating system prompt, type 
% seqmerge  

The SeqMerge Project Manager appears.  For more information, see Chapter 3, 
Working in the Project Manager. 

   

You can keep your terminal free for other work by running SeqMerge in the 
background.  To do so, type the following to start SeqMerge: 
 
% seqmerge & 
Note:  You may see a message similar to the following: 
 
Error: Can't open display: 172.26.65.28:0.0 

[1]    Exit 1                 seqmerge 
 

if so, you need to tell the computer which X server you are using.  For example, 
type 
 
% setenv DISPLAY node_name:server_number.screen_number  
 

 
Where server_number refers to an instance of the X server program and 
screen_number refers to the number of screens created by the program 
(usually 0). If one server exists, the server_number is 0; if multiple servers 
exist, each is assigned a sequential number.  If you have multiple screens 
attached to your computer, the first screen will be number 0, the second will be 
number 1, etc.  In most cases the server_number. screen_number will be 
0.0.  
 
See your system manager for more information. 
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Starting SeqMerge from SeqLab 

To start SeqMerge from SeqLab: 

From the Functions menu, choose Fragment Assembly -> SeqMerge. 

The SeqMerge Project Manager appears.  For more information see Chapter 3, 
Working in the SeqMerge Project Manager. 

Accessing online help 

To access SeqMerge online help: 

Click on the Help button in the dialog box in which you are working.  The 
SeqMerge Help window appears and describes the options available to you 
within your current dialog box. 

 

Quitting SeqMerge and logging off 

To quit your work with SeqMerge: 

From the File menu, choose Exit. 

To log off the computer: 

After you have exited from SeqMerge (and SeqLab if you started SeqMerge 
within SeqLab), type 
 
% exit  
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2. SeqMerge Tutorial 

Introduction 

This tutorial provides a brief introduction to and hands-on practice with the 
primary functions of SeqMerge.  It is not intended to be comprehensive.   

The lessons in this tutorial build upon one another; they are designed to be 
completed in the order they appear.  This tutorial will take about one hour to 
complete.  After completing this tutorial, you should be able to quickly create 
contigs from your own fragments. 

What do I need? 

To use this tutorial, you need: 

• An account to run GCG at a licensed site 

• SeqMerge installed at the licensed site 

• A networked UNIX workstation running X Windows or a networked PC or 
Macintosh running X server software 

These tutorial lessons assume that you are familiar with working with dialog 
boxes and with using a mouse to select, click, and drag.  Some familiarity with 
your system’s UNIX operating system will also be useful.  In addition, if you 
require an X server to display SeqMerge on your PC or Macintosh, we 
recommend that you take time to learn how to use it before using SeqMerge. 

The exercises in this tutorial require example vector and fragment files.  These 
files are available in the directory with the logical name SeqMergeDemoData. 

What will I learn? 

This tutorial is designed as a quick overview of some of the primary functions of 
SeqMerge.  You will perform the steps in the following sections to create a 
small sequencing project and assemble fragments into a contig. 

• Starting SeqMerge.  Shows you how to start SeqMerge from a GCG 
environment via the command line or SeqLab, the X Windows based 
graphical user interface to GCG. 

• Creating a sequencing project.  Describes how to create and manage 
sequencing projects.   

• Adding fragments to a project.  Shows how to enter new fragments into a 
project. 
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• Finding and masking vector sequences.  Takes you through the steps of 
adding and masking vector sequences within your project.  If any of the 
fragments include vector contamination, you’ll want to mask the vector 
region so that it doesn’t affect the assembly. 

• Assembling fragments.  Describes how to construct a single contig from 
masked fragments. 

• Viewing the contig.  Demonstrates how to view a contig in the SeqMerge 
Contig Editor. 

• Navigating through the contig.  Shows how to maneuver through the 
fragments in your contig. 

• Editing contigs.  Shows how to edit the bases in a contig when you have 
fragment discrepancies. 

• Exporting contig consensus sequences.  Shows how to make contig 
consensus sequences available to other GCG programs.  

• Exiting SeqMerge.  Describes how to exit SeqMerge. 

Before you begin 

Before you begin the tutorial, there are a few steps you must take in preparation: 

1. If you are using a PC or Macintosh, start your X server software and open a 
terminal emulation window, such as Xterm or DECterm. 

2.  Initialize GCG  environment by typing: 
% source <Installed directory path> gcgstartup 
% gcg 
The system takes a few seconds to initialize the GCG environment and then 
display GCG banner. 

Initializing GCG environment gives you access to GCG programs, 
databases, and auxiliary files required for SeqMerge to run smoothly. 

Note: The gcg command is how the package is initialized at most sites.  If 
this command is not recognized at your site, see your system manager. 

Starting SeqMerge 

To start SeqMerge. 

Choose one of the following: 

• From SeqLab, select Fragment Assembly -> SeqMerge from the Functions 
menu. 

• From the UNIX command line, type the following: 
% seqmerge & 
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The SeqMerge Project Manager appears.  You are now ready to begin working 
with your sequencing project. 

If an error message appears, try initializing the package again.  If you still have 
trouble, see your system manager. 

Creating a sequencing project 

To create a project: 

1. From the Project menu, choose Create Project...   
The Create New Project dialog box appears. 

2.  In the “Type new project directory name here” text box, type demo after the 
displayed directory path. 

3. Click OK. 
The Create New Project dialog box closes, and you now have a new 
sequencing project named demo. 

                    

Adding fragments to a project 

To add fragments to your demo project: 

1. From the Project menu of the SeqMerge Project Manager, choose Add 
Sequences From -> Sequence Files.... 
The Add Sequence Files dialog box appears. 

2. Delete the file specification information from the Filter text box and type 
seqmergedemodata:*.SCF in its place. 
Note:  The SCF must be in uppercase. 

3.  Click the Filter button. 
The Files scroll list now contains all of the example fragments you’ll add to 
your sequencing project. 
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4.  Select all of the fragments in the Files scroll list. 

Click on the first fragment in the list. 
• Scroll to the bottom of the list. 
• Shift-click (press and hold the <Shift> key while clicking) on the last 

fragment in the list. 

5.  Accept the default parameters for fragment end masking and click OK. 
The selected fragments are added to your sequencing project.  For more 
information, see “Adding Fragments to a Project” in Chapter 3, Working in 
the Project Manager.  

6.  Click Cancel. 
The Add Sequence Files dialog box disappears, and you are left with the 
SeqMerge Project Manager. 

Finding and masking vector sequences 

If any of the fragments contain vector contamination at their ends, you’ll want to 
mask the contaminating region before assembling the fragments so the 
contamination doesn’t affect the assembly.   

SeqMerge allows you to a) specify and add the vectors you used for sequencing 
to your project, b) scan your fragments for contaminating vector sequence, and 
c) mask, or hide the contaminating sequence from the assemble program. 

Note:  For details on the steps in this part of the tutorial, see Chapter 4, Masking 
Vector Sequences. 

To add vector sequences to your project: 

1.  From the Project Menu in the SeqMerge Project Manager, select Vectors... 
The SeqMerge Vector Manager dialog box appears. 
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2.  Click Add From Files... 
The Add Vector Files dialog box appears. 

3.  Delete the current filter from the Filter text box and type 
SeqMergeDemoData:*.vector in its place. 

4.  Click Filter. 
The Files scroll list now contains all of the example vector sequences you’ll 
want to select for your sequencing project. 

                     
 

5. Select both vector sequences in the Files scroll list.  
• Click on the first sequence in the list. 
• Shift-click on the second sequence in the list. 

6. Click OK. 
The selected vector sequences are now added to your sequencing project. 

7. Click Cancel. 
The Add Vector Files dialog box disappears, and the SeqMerge Vector 
Manager Dialog box appears. 

To mask vector sequences: 
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1. Select both vector sequences by clicking Select All in the SeqMerge Vector 
Manager Dialog box. 
Both vector sequences in the list should be highlighted. 

2. Click Scan Project. 
SeqMerge proceeds to check your fragments for the presence of vector 
sequences.  If SeqMerge finds vector sequences at the ends of the 
fragments, it masks those sequences so they won’t affect the assembly. 

3.  Click Scan Project again. 
Note:  SeqMerge masks only the ends of fragments.  Therefore, if you have 
nested vector sequences (as in this tutorial), you may need to scan the 
project again to ensure that you masked all vector sequences. 

4.  Click Close. 
The SeqMerge Vector Manager Dialog box disappears and you are left with 
the SeqMerge Project Manager.  (SeqMerge displays a “V” in the Mask 
column if a fragment contains masked vector sequence.) 

Note:  You must scan and mask vector contamination from fragments before 
assembling them.  Once fragments are included in contigs, they cannot be 
masked.  (If you decide to mask a fragment that is part of a larger contig, you 
must disassemble the contig first.) 

Assembling fragments 

SeqMerge assembles your fragments into contigs.  In this example project, all 
fragments assemble into a single contig.  

Note:  For details on the steps in this part of the tutorial, see Chapter 5, 
Assembling Fragments. 

To assemble the fragments of your project: 

1. From the Assemble menu of the SeqMerge Main Window, choose 
Assemble.... 
The Assemble Project dialog box appears. 

2.  Verify that “Assemble All Contigs” is selected at the top and that 
“Assemble Current Contigs” is selected at the bottom of the dialog box. 
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3.  Click OK. 
After the assembly is complete, the Assemble Project dialog box disappears 
and you are left with the SeqMerge Project Manager.  The window now 
contains a single contig named ai0723sa.  This name is derived from the 
left-most sequence in the contig alignment. 

Viewing the contig 

The fragments have been assembled into a single contig that can be viewed in 
the SeqMerge Contig Editor. 

To view a contig: 

1. Open the SeqMerge Contig Editor and select contig ai0723sa for viewing.  
Choose one of the following: 
• Double-click on ai0723sa in the SeqMerge Main Window. 
• Select ai0723sa in the SeqMerge Main Window by clicking on it, and 

then choose Edit Selected Contigs from the Edit menu. 
The SeqMerge Contig Editor appears with the ai0723sa contig loaded into 
the editor.   

2. Resize the window to view more of the alignment by clicking and dragging 
a border of the window.   

3.  Change the size of the work areas for the contig data and contig graph by 
clicking and dragging the window shade’s rectangle, above and to the right 
of the contig graph. 

                     

To view the masked vector sequences in the alignment. 
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1. Position the cursor anywhere on the fourth row of the alignment.  An arrow 
appears to the left of the fragment name, ei0420ra, indicating that the cursor 
is positioned on this row.  This name is preceded by a “V”, indicating that 
this fragment contains masked vector sequence. 

2.  Press <Ctrl>B to position the cursor at the beginning of this fragment.  The 
first 596 bases of this fragment are colored gold, indicating that they are 
masked vector sequence.  These 596 bases were masked earlier in the 
“Finding and Masking Vector Sequences” section and were then ignored 
during contig assembly. 

Navigating through the alignment 

SeqMerge provides several ways to help you navigate through the fragments in a 
contig. 

Note:  For details on the steps in this part of the tutorial, see “Navigating 
through Contigs” in Chapter 6, Working in the Contig Editor. 

To navigate through the alignment, choose one of the following: 

• Use the scroll bars below and to the right of the contig alignment to find a 
specific position within the contig. 

• Position the cursor in the contig alignment with a mouse click and use the 
keyboard arrow keys. 

• Use the greater than and less than signs (< and >) to scroll horizontally, one 
page at a time. 

• Type a number and press <Return> to move to that position in the alignment.  
For instance, typing 1300<Return> moves you to position 1300 in the current 
alignment. 

• Click on one of the bars in the contig schematic located in the lower part of 
the SeqMerge Contig Editor.  Each bar represents one fragment.  The 
sequence data for that region of the contig is displayed in the editor. 

a. Click and drag the target box in the contig graph. 

b. From the Navigate menu, choose from the following options: 

• Move to the beginning or ending of the current fragment by selecting 
Beginning of Fragment or End of Fragment. 

• Move to the next position of mismatch in the consensus sequence by 
selecting Next Mismatch in Alignment. 

• Move to the next position of mismatch with the current fragment by 
selecting Next Mismatch in Fragment. 

• Move to the next gap in the consensus sequence by selecting Next 
Gap in Consensus. 
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Editing contigs 

You may want to edit a contig alignment to resolve inconsistencies among the 
fragments at a specific column: 

Note:  For details on the steps in this part of the tutorial, see “Editing in the 
Contig Editor” in Chapter 6, Working in the Contig Editor. 

To edit the contig: 

1. Position the cursor anywhere on the third row of the alignment.  An arrow 
appears to the left of the fragment name, mf1124sa, indicating that the 
cursor is positioned on this row. 

2.  Press <Ctrl>B to position the cursor at the beginning of this fragment. 

3.  From the Navigate menu, choose Next Gap in Consensus. 
The cursor moves to the next column in this fragment where there is a gap 
character in the consensus sequence.  Your cursor should be positioned on a 
T at position 1250.  Note that all other fragments have a gap character in 
this column of the alignment.  You may suspect that the additional T in 
fragment mf1124sa at position 1250 may be due to a miscalled additional 
base in the trace chromatograms. 

4.  View the trace chromatograms of the fragments at this position.  Choose 
one of the following: 
• Double-click on the T at position 1250. 
• From the File menu, choose Show Traces. 
The SeqMerge Trace Viewer appears and displays the trace chromatograms 
for fragment mf1124sa, centered at position 1250. Note the peak at this 
position is ill-formed and very broad.  Compare this chromatogram with the 
same region in other fragments by scrolling through the other fragments in 
the Trace Viewer.  You may conclude that the additional T at position 1250 
in fragment mf1124sa is due to a miscalled additional base. 

5. Delete column 1250, containing the miscalled additional base, from the 
contig alignment. 
• Type 1251<Return> 

The cursor is positioned one column to the right of the column you wish 
to delete 

• Press the <Delete> key. 

SeqMerge deletes the column to the left of the cursor from all 
fragments, including the consensus.  All fragments are still aligned 
properly after this column deletion. 

Note:  You can edit one fragment at a time rather than all of them by 
clicking the Keyboard menu button and selecting Current sequence. 
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For more information, see “Editing in the Contig Editor” in Chapter 6, Working 
in the Contig Editor. 

Exporting contig consensus sequences 

Once you’ve resolved inconsistencies among the fragments in your contig 
alignment, you may wish to export the contig consensus sequence for use with 
other GCG programs. 

To export a contig consensus sequence: 

1. From the File menu in the SeqMerge Contig Editor, choose Export 
Consensus.... 

2.  Verify that Export All Consensus Sequences is selected. 

3.  Type the name of the file in the RSF FileName: text box. 

4.  Click OK. 
SeqMerge creates an RSF file containing the contig consensus sequence.  If 
the output file is named seqmerge.rsf, the consensus sequence can be 
specified as seqmerge.rsf{consensus}. 

Exiting SeqMerge  

To exit SeqMerge: 

1. From the SeqMerge Contig Editor, choose Close from the File menu. 

2.  Click Yes to save your changes. 

3.  From the SeqMerge Project Manager, choose Exit from the Project menu. 
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3. Working in the Project Manager 
The SeqMerge Project Manager provides options for doing tasks like these: 

• Creating a new sequencing project 

• Selecting an existing project 

• Adding fragments and, if necessary, vector sequences to the project 

• Masking vector contaminating sequence from fragments in the project 

• Assembling fragments into alignments called contigs 

• Accessing the SeqMerge Contig Editor which enables you to view and 
modify fragments in the contig 

• Exporting the contig consensus sequences for use with other programs 

• Exiting SeqMerge 

Overview 

SeqMerge holds fragments in a sequencing project.  From this project, you can 
view, edit, and assemble your fragments into contigs, or alignments of 
overlapping fragments. 

The standard steps in a sequencing project are to: 

• Create a project. 
• Add fragments to the project. 
• Mask vector sequences if required. 
• Assemble fragments into contigs. 
• View and edit the results. 

When you start SeqMerge, it opens to the most recent project you accessed and 
displays it in the SeqMerge Project Manager.  You can create a new project and 
add sequences to it or open another existing project.  For more information on 
creating and managing sequencing projects, see “Working with Projects” in the 
next chapter.  The illustration below shows an example SeqMerge Project 
Manager. 
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Menu bar 

Pull-down menus on the menu bar list the commands you use to do your work. 

Sort selector 

Lets you change the order in which a project’s contigs are listed.  You can list 
them alphabetically, by number of fragments, by total length, or by modification 
time.   

Multiple Fragment Viewer 

Displays a plus sign (+) if the contig consists of more than one fragment. (Click 
on the plus sign to display a list of the fragments in the contig.  Fragments in the 
list containing masked vector sequence have a “V” displayed in front of their 
names.) 

Project data 

Displays the contigs in your current project.  This area identifies the following: 

• name of each contig 

• number of fragments in the contig 

• length of the contig 

• presence of masked vector sequence in the contig 

• time the contig was last modified 

SeqMerge project manager menu items 

The standard steps in a sequencing project are to 1) create a project; 2) add 
fragments to the project; 3) mask vector sequences if required; 4) assemble 
fragments into contigs, and 5) view and edit the results.  You access the tools to 
perform these steps from one of the following three menus of the SeqMerge 
Project Manager: 
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Project 

Select options from this menu to create or open existing projects, add fragments 
to a project, find and mask vector sequences, export contig consensus sequences, 
or quit SeqMerge.  

Edit 

Choose options from this menu to select contigs to view and edit in the 
SeqMerge Contig Editor.  For more information, see Chapter 6, Working in the 
SeqMerge Contig Editor. 

Assemble 

Select options from this menu to assemble or disassemble your current contigs. 

At any time during the assembly process, you can use the SeqMerge Contig 
Editor and Trace Viewer to view and edit your fragments and contigs.  
SeqMerge returns you to the SeqMerge Project Manager when you close the 
Contig Editor, so you can reassemble your edited contigs. 

The rest of this chapter describes how you create and manage sequencing 
projects in the Project Manager. 

Creating a sequencing project 

To keep track of the fragments in your sequencing project, you create a project 
and add fragments to it.   

Note:  SeqMerge creates a project directory with the project name you specify.  
This new directory maintains all of the information needed to assemble the 
original or edited fragments in the project. 

To create a new project: 

1.  Choose Create Project... from the Project menu.  The Create New Project 
dialog box appears. 

 



 
25 Accelrys GCG 

                     
Filter   

Displays the pathname of the current directory and the filter is used to 
display the contents of that directory.  The filter helps you display only the 
subdirectories or files you want to see in the Files and Directories scroll list.  
For example, typing A* after the directory path displays only those 
subdirectories or files starting with the letter A .  The * is a wildcard that 
means “anything or nothing.”  To display all subdirectories or files in the 
Files and Directories scroll list, type * after the directory path. 

You can type a complete directory specification and filter directly in the 
Filter text box and press <Return> or click the Filter button to display 
subdirectories or files in the directory. 

Navigate 
Displays the subdirectories within the current directory that are not projects.  
To move to a different directory, select a new one with the mouse and click 
the Filter button or simply double-click on the directory to which you want 
to move.  The Files and Directories scroll list displays the subdirectories 
and files in the new directory. 

Note:  The current directory is represented as a period (.) in the Navigate 
list, and the parent directory is represented as two periods (..).  Therefore to 
move up one directory, double-click on the .. specification. 

Files and Directories 
Displays the subdirectories and files in the current directory that match the 
filter.  Use this area to choose an appropriate name for your project.  
SeqMerge displays the files and directories in gray because it will not allow 
you to create a new project with an existing name. 

Type new project directory name here: 
Displays the path to the current working directory.  Type the name for your 
project here. 

2.  In the Filter text box, enter the name of the parent directory for your new 
project or use the Navigate frame to move to a different parent directory. 
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3.  Type the name of your project after the directory path in the “Type new 
project name here:” text box.  You must choose a unique name for your 
sequencing project. 
Note:  SeqMerge substitutes underscores (_) for spaces in project names.  For 
example, if you type My Project, SeqMerge will name your project 
My_Project. 

4.  Click OK. 
SeqMerge creates a project with the new project name.  The SeqMerge 
window displays the name and path to the project, and indicates that no 
fragments have been added to the project.  To add fragments to the project, see 
“Adding Fragments” in this chapter. 

Opening an existing project 

You can have more than one sequencing project at any time.  However, you can 
only work on one project in any SeqMerge session.  If you want to work on 
more than one project at a time, you must start a new SeqMerge session for each 
project. 

Note:  You can share sequencing projects with your colleagues.  However, be 
sure to coordinate your time in the project because SeqMerge does not monitor 
project activity.  SeqMerge saves the project as it was last saved by anyone who 
accessed it. 

To open an existing project and display its fragments in the SeqMerge Project 
Manager. 

Choose from the following: 

• Find a project you recently accessed: 

a. Select Recent Projects from the Project menu of the SeqMerge Project 
Manager. 

b. Choose the path to the project you recently accessed. 

    
 
• Open a project by browsing the file system. 
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a. Select Open Project... from the Project menu of the SeqMerge Project 
Manager.  The Open Existing Project dialog box appears. 

 
Filter   

Displays the pathname of the current directory and the filter used to 
display the SeqMerge projects in that directory.   

Also, you can type a directory specification and filter directly in the 
Filter text box and press <Return> or click the Filter button to display 
projects in the directory. 

Navigate 
Displays the directories contained within the current directory.  To 
move to a different directory, select a new one with the mouse and click 
the Filter button or simply double-click on the directory to which you 
want to move.  The Existing Projects scroll list displays the SeqMerge 
projects in the new directory. 

Note:  The current directory is represented as a period (.) in the 
Navigate list, and the parent directory is represented as two periods (..).  
Therefore to move up one directory, double-click on the .. specification. 

Existing Projects 
Displays the sequencing projects in the current directory.  Use this area 
to choose an appropriate name for your project.   

Selection 
Displays the path to the current working directory.  Select the name of 
your project from the list. 

b. Select an existing project from the Existing Project scroll list or type in 
a complete path specification to an existing project in the Selection text 
box.   

c. Click OK.  SeqMerge displays the project’s contigs in the Project 
Manager.   
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Tip: You and your co-workers can all access the same project, as long as 
you have the appropriate permission.  However, if you edit a project at the 
same time as a co-worker, you could lose your changes.  If you share 
projects with other people, be sure to coordinate your time working in the 
project so you don’t lose any work. 
 

Importing a GelMerge project into SeqMerge 

You can move projects created with GCG Fragment Assembly System into 
SeqMerge. 

Note:  Once you have moved a GCG Fragment Assembly project into 
SeqMerge, you can no longer access it from GCG’s fragment assembly 
programs.  You might want to save a backup copy in GelMerge format. 

To move GCG Fragment Assembly Projects into SeqMerge: 

1. Select Open Project... from the Project menu of the SeqMerge Project 
Manager.  The Open Existing Project dialog box appears. 

                     
  

2. Type the name of your GCG fragment assembly project in the Selection text 
box, or select the project name from the Existing Projects scroll list. 

3. Click OK.  The Converting Old Project dialog box appears.  

4. Click Yes to convert your project to SeqMerge format. 

5. The project’s contigs appear in the SeqMerge Project Manager. 
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Adding fragments to a project 

After creating a sequencing project, you add your fragments to the project.  
SeqMerge lets you add fragments acquired from automated sequencers (ABI and 
SCF data formats) or from GCG sequence files such as single sequence, list, 
MSF, RSF, and GCG database files. 

Note:  You can add more fragments to a project at any time.   
What happens to fragments when you add them to a project? 

When you add a fragment to a project, SeqMerge 

• Automatically masks the ends of the fragments so that ambiguous bases 
(typical of low-quality calls at the ends of fragments) do not participate 
in the contig alignment.  Poorly sequenced ends can keep SeqMerge 
from recognizing good overlaps, which are determined as a fraction of 
matching words (short, contiguous runs of bases, usually 3-8 bases 
long) over the length of the complete overlap.  A lack of matching 
words at the ends of overlaps because of poor sequencing data prevents 
SeqMerge from recognizing otherwise good overlaps.   

Note:  When SeqMerge masks fragment ends, it does not delete the 
data, it only hides it from the assembler so that the low-quality ends do 
not adversely affect the alignment. 

• Creates new GCG-readable format files from ABI or SCF format files, 
without altering the original files.   Because the original files do not 
change, several sequencing projects can access the same trace files. 

Note:  SeqMerge expects the ABI or SCF files to stay in the directory 
from which they were added.  If you rename them or remove them from 
their original directory location, you will not be able to view them in the 
Trace Viewer.  For more information on viewing ABI and SCF files in 
the Trace Viewer, Chapter 7, Working in the Trace Viewer. 

Adding fragments from files 

Adding single fragments files 

You can add single sequence files in ABI-, SCF-, or GCG-formats.  GCG single 
sequence formats include single sequence files, rich sequence format (rsf) files 
and GCG database sequences. 

SeqMerge masks poor-quality fragment ends when you add them to a project.  
However, you can turn off or change the default masking by changing the 
masking parameters. 

To add single fragments to your project: 
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1. From the Project menu, choose Add Sequences From -> Sequence Files.... 
The Add Sequence Files dialog box appears. 

                     

2. Use the Add Sequence Files dialog box to locate the one or more files you 
want.  Choose from the following: 
• Type the specification directly in the Selection text box.   
• Navigate the directory hierarchy to display the one or more files you 

want. 

3. To select one or more files: 
• Select one file by pointing to it and clicking the left mouse button.  

(Double-click on the file to select and add the file to your project in one 
step.) 

• Select adjacent files by pressing the left mouse button and dragging the 
mouse to include all the files you want. 

• Select adjacent files by shift-clicking.  Point to the first file and click 
the left mouse button.  Then, point to the last adjacent file you want to 
select, press <Shift> and click the left mouse button.  All the files 
between the two clicks are highlighted. 

• Select non-adjacent files by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each file you want. 

4. Specify the following masking parameters: 
Mask Low-Quality Ends 

Masks fragment ends when the data quality does not meet what you specify 
in the Window and Max % Ambiguity parameters.  To prevent SeqMerge 
from masking low-quality ends, uncheck this box. 

Note:  When SeqMerge masks fragment ends, it does not delete the data, it 
only hides it from the assembler so that the low-quality ends do not 
adversely affect the alignment.  Masking is always reversible; as you build 
the alignment, you can mask or unmask any parts of a fragment at any time 
from the SeqMerge Contig Editor or the SeqMerge Trace Viewer. 
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Window 
Specifies the number of bases SeqMerge uses to calculate the percent 
ambiguity in fragment ends.  The exact calculation and its consequences are 
described in the Max % Ambiguity parameter below.  The default Window 
is 50. 

Percentage (Max % Ambiguity) 
Specifies the percent ambiguity at which you want SeqMerge to mask 
fragment ends.  SeqMerge masks bases from the ends until it finds a 
window that has a percent ambiguity that is not higher than this parameter 
value, and that begins with seven unambiguous bases.  For example, if you 
specify a Max % Ambiguity of 5, and a Window of 50, SeqMerge Slides a 
window of 50 inward from the end of the fragment.  As soon as it finds a 
window that begins with seven unambiguous bases, and also has no more 
than 5 percent ambiguity (less than 3 mismatches), the sliding stops.  
SeqMerge then masks all bases to the left of the window.  It repeats the 
process on the other end of the fragment.  The default Max % Ambiguity is 
5. 

5.  Click OK to add the selected sequence(s) to the project. 

6.  Click Cancel to close the dialog box. 
 

Adding multiple fragments from list, RSF, and MSF Files 

GCG stores lists of sequences in list files, multiple sequence format (MSF) files, 
or rich sequence format (RSF) files.  You can add fragments into SeqMerge 
from any of these files by selecting the file as you would a single sequence file.  
For more information on adding fragments from single sequence files, see 
“Adding Single Fragment Files,” in the previous section. 

Note:  All GCG file formats (single, list, MSF, and RSF) must include a File 
Type in the first line of the file, for example!!SEQUENCE_LIST 1.0.  (GCG 
programs automatically create a File Type in output files.) 

 

Adding fragments from a GCG database 

You can use the SeqMerge Database Browser to look into the databases and see 
what sequences they contain.  From it you can display the individual sequences 
within each database available at your site as well as those within personal 
databases you may have created.  You can add single sequences (for example 
gb_sy:cvu47119) or multiple sequence specifications using wildcards (for 
example gb_sy:cvu*). 

To add sequences from a GCG database: 
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1. Choose Add Sequences From -> Databases... from the Project menu.  The 
SeqMerge Database Browser appears, allowing you to choose sequences 
from the various databases available at your site. 

                     
  

2. Select the sequence(s) you want.  Choose from the following: 
• If you know the accession number or name of the sequence(s) you are 

interested in: 
a. Type the specification in the Database Specification: text box.  Or, 

if you know the accession number of the sequence, you could type 
that number in the text box.   

b. Press <Return> or click the Show Matching Entries button.  
Matching entries display in the Entries: list area.  Scroll through the 
window to find the sequence(s) you want.  Click on the Next 200 
Matches or Previous 200 Matches button to move through the 
sequences. 

c. Select one or more sequences.   

If you want to browse through the sequence databases: 
a. Click on the database you want to view in the Databases: list area.  

Note that the Database Specification: text box displays the database 
specification you choose.  If you know the specification for the 
sequence(s) you want, you can type directly in the Database 
Specification: text box. 

Note:  If you have a personal database that does not appear in the 
list of databases, type its database logical name in the Database 
Specification: text box, for example, myData:*. 

b. Click on the Show Matching Entries button.  The Entries: list area 
displays the matching sequences 200 entries at a time.  Scroll 
through the list to find the sequence(s) you want.  Click on the Next 
200 Matches or Previous 200 Matches button to move through the 
sequences. 

c. Select one or more sequences. 
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3.  Specify the masking parameters.  For more information, see “Adding 
Fragments From Files,” in the previous section. 

4.  Click Add to add the selected sequences to the project. 

5.  When you finish with the Database Browser window, click the Close 
button. 

Removing fragments from a project 

To remove fragments from a project: 

1. Make sure the fragments you want to remove are not part of a multiple-
fragment contig.  If they are, disassemble them so that they become single-
fragment contigs.  For more information, see “Disassembling Contigs” in 
Chapter 5, Assembling Fragments. 
Note:  SeqMerge views all fragments in a sequencing project as part of a 
contig.  Fragments that have not been assembled appear as single-fragment 
contigs in the Project Manager.  (SeqMerge does not display a plus sign (+) 
in front of single-fragment contig names.) 

2.  From the Project Manager, select the single-fragment contigs you want to 
remove: 
• Select one contig by pointing to it and clicking the left mouse button. 
• Select adjacent contigs by pressing the left mouse button and dragging 

the mouse to include all the fragments you want. 
• Select adjacent contigs by shift-clicking.  Point to the first contig and 

click the left mouse button.  Then, point to the last adjacent contig you 
want to select, press <Shift> and click the left mouse button.  All the 
contigs between the two clicks are highlighted. 

• Select non-adjacent contigs by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each contig you want. 

3.  Select Remove Selected Contigs from the Edit menu.  The Confirm 
Removal Dialog box appears. 

4.  Click OK to confirm removal. 

Viewing fragments 

Once you have added fragments to a project, you may want to find, view, or edit 
the sequence data.   

Finding fragments by name 

To locate any fragment in your project by name: 
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1. Select Find Fragment... from the Edit menu of the SeqMerge Project 
Manager.  The Find Fragment dialog box appears. 

                     

2. Enter the name of the fragment you are looking for in the Fragment Name 
text box. 

3. Click OK.  SeqMerge will highlight the fragment with that name in the 
Project data section of the SeqMerge Project Manager.  If the fragment is 
part of a multiple-fragment contig, SeqMerge displays the Multiple Contig 
dialog box for the associated contig with the fragment name selected. 

Viewing and editing fragments 

You view or edit fragments you have added to a SeqMerge project from the 
SeqMerge Contig Editor.  For more information, see Chapter 6, Working in the 
Contig Editor. 

You can also view the traces for fragments that you added to SeqMerge from 
ABI or SCF trace files.  For more information on the Trace Viewer, see Chapter 
7, Working in the Trace Viewer.  

Exporting contig consensus sequences 

At any time, you can save the contig consensus sequences in your SeqMerge 
project to a single RSF file, which can be used for further analysis by other GCG 
programs. 

Note:  SeqMerge does not include gaps in the output file. 

To export the consensus sequences for contigs: 

1.  Select one or more contigs you want to export: 
• Select one contig by pointing to it and clicking the left mouse button. 
• Select adjacent contigs by pressing the left mouse button and dragging 

the mouse to include all the contigs you want. 
• Select adjacent contigs by shift-clicking.  Point to the first contig and 

click the left mouse button.  Then, point to the last adjacent contig you 
want to select, press <Shift> and click the left mouse button.  All the 
contigs between the two clicks are highlighted. 

• Select non-adjacent contigs by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each contig you want. 

• Select all contigs by clicking the Export All Contigs Button. 
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2. Select Export Consensus... from the Project menu.  The Export Consensus 
Sequences dialog box appears. 

                     
3.  Use the Export Consensus Sequences dialog box to help you find the 

appropriate directory and name for your new file. 
• Type a directory specification in the Filter text box and click Filter to 

see the list of subdirectories in the Navigate scroll list and already 
existing files in the Files scroll list.   

• Navigate the directory hierarchy to locate the directory you want to 
place your new file. 

• Append the name of your new file to the end of the directory path in the 
Selection text box. 

4. Specify the export mode.  Choose from the following: 
• Click the Export All Consensus Sequences button to export all of the 

contigs in your sequencing project. 
• Click the Export Selected Consensus Sequences button to export only 

the contigs you selected in step 1.  
5. Click OK to export the consensus sequences. 
6. Click Cancel to close the dialog box. 

Exporting the consensus sequence for a single fragment 

To export the consensus sequence for specific fragments within a multiple-
fragment contig: 

1. Select the contig and bring it into the Contig Editor.  For more information 
on the Contig Editor, see Chapter 6, Working in the Contig Editor. 

2.  Select the fragment name(s) in the contig data section of the Contig Editor. 

3.  Choose Export... from the File menu.  The Export dialog box appears. 

4.  Select the Export Selected Fragments button. 

5.  Use the Filter, Directories, and Files sections of the dialog box to choose 
the location and name for the new fragment(s) file.   
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6.  Type the name of the file after the directory path in the Output RSF File: 
text box. 

Note:  Check the Include Trace Data box if you want to export both the 
consensus sequence and the trace file data. 

Reverting to original fragments 

If at any time you need to start your assembly from scratch, you can revert to the 
original, unedited fragments.  For more information, see “Disassembling 
Contigs” in Chapter 6, Working in the Contig Editor. 
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4. Masking Vector Sequences 

Overview 

Sequence data generated in sequencing projects often contains extraneous vector 
sequence required for cloning and sequencing, which can adversely affect 
fragment assembly.  For example, you could have two fragments whose only 
overlap is from the vector.  The overlapping vector could cause these two 
unrelated fragments to be falsely aligned.  Alternatively, two fragments may 
have strong overlap, but one of the fragments contains vector.  The vector in this 
case can prevent the strong overlap from being recognized, and the two 
fragments may not be aligned. 

SeqMerge allows you to avoid the influence of vectors in fragment assembly by 
masking, or hiding the vector sequence before you do the alignment.  When you 
mask vector sequence in fragments, the sequence is not removed from the 
fragments; it is simply hidden from the program that performs the assembly.   

This chapter describes how to hide vector sequence so it doesn’t interfere with 
the assembly. 

Note:  SeqMerge only checks for vector near the ends of fragments, and only in 
single-fragment contigs. 

To mask vector sequence, you simply specify which vectors you want SeqMerge 
to look for, and then you scan your fragments and SeqMerge masks them.   

SeqMerge searches for vector sequence in each fragment by looking for regions 
of overlap between the vector and the fragment.  (You can fine tune the vector 
searching algorithm by altering the default masking parameters.) 

At any time you can unmask the masked sequence data, remask with different 
masking parameters, and extend or reduce the mask if you find that you can 
improve SeqMerge’s automatic vector masking by hand.   

For more information on the algorithm that masks vector sequence, see 
Appendix C, The SeqMerge Algorithms. 

Tip: Your system administrator may have installed the GCGVector database.  
This database was created from GenBank vector database entries.  You may 
want to search this smaller database to locate your vector sequences.  For 
example, use GCG’s StringSearch program to find your vector by name and add 
it to your sequencing project.  For more information on the StringSearch 
program, see “StringSearch” in the Program Manual. 
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Adding vector sequences to mask 

Adding vector sequences from files 

To add vector sequences from sequence files: 

1. Select Vectors... from the Project menu of the SeqMerge Project Manager.  
The SeqMerge Vector Manager appears. 

                     

2. Click the Add From Files button.  The Add Vector Files dialog box appears. 

3. Use the dialog box to locate the one or more files you want.  Choose from 
the following: 
• Type the file specification directly in the Selection text box. 
• Navigate the directory hierarchy to display the one or more files you 

want. 

4. To select one or more files: 
• Select one file by pointing to it and clicking the left mouse button. 
• Select adjacent files by pressing the left mouse button and dragging the 

mouse to include all the files you want. 
• Select adjacent files by shift-clicking.  Point to the first file and click 

the left mouse button.  Then, point to the last adjacent file you want to 
select, press <Shift> and click the left mouse button.  All the files 
between the two clicks are highlighted. 

• Select non-adjacent files by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each file you want. 

5. When you’re finished, click OK to add the selected vector file(s) to the 
project. 

6. Click Cancel to close the Add Vector Files dialog box. 
Adding vector sequences from a GCG database 

To add vector sequences from a GCG database: 
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1. Select Vectors... from the Project menu of the SeqMerge Project Manager.  
The SeqMerge Vector Manager appears. 

2.  Click the Add From Database... button.  The SeqMerge Database Browser 
appears. 

   Tip: Your system administrator may have installed the GCGVector 
database.  This database was created from GenBank vector database entries.  
You may want to search this smaller database to locate your vector 
sequences.  For example, use GCG’s StringSearch program to find your 
vector by name and add it to your sequencing project.  For more 
information on the StringSearch program, see “StringSearch” in the 
Program Manual.  

                     

3. Select the sequence(s) you want.  Choose from the following: 
• If you know the accession number or name of the sequence(s) you are 

interested in: 
a. Type the specification in the Database Specification: text box.  Or, 

if you know the accession number of the sequence, you could type 
that number in the text box.   

b. Press <Return> or click the Show Matching Entries button.  
Matching entries display in the Entries: list area.  Scroll through the 
window to find the sequence(s) you want.  Click on the Next 200 
Matches or Previous 200 Matches button to move through the 
sequences. 

c. Select one or more sequences.  Choose from the following: 

• Select one sequence by pointing to it and clicking the left mouse button. 

• Select adjacent sequences by pressing the left mouse button and 
dragging the mouse to include all the sequences you want. 

• Select adjacent sequences by shift-clicking.  Point to the first sequence 
and click the left mouse button.  Then, point to the last adjacent 
sequence you want to select, press <Shift> and click the left mouse 
button.  All the sequences between the two clicks are highlighted. 
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• Select non-adjacent sequences by control-clicking.  To do so, press 
<Ctrl> and click the left mouse button on each sequence you want. 

• If you want to browse through the sequence databases: 
a. Click on the database you want to view in the Databases: list area.  

Note that the Database Specification: text box displays the database 
specification you choose.  If you know the specification for the 
sequence(s) you want, you can type directly in the Database 
Specification: text box.  If you only know the first part of the name, 
use a wildcard.  For example, typing A* after the directory path 
displays only those subdirectories or sequences starting with the 
letter A.  The * is a wildcard that means “anything or nothing.”  To 
display all sequences in the Entries: list, type * after the database 
name, for example Bacterial:a16*. 

b.  Click on the Show Matching Entries button.  The Entries: list area 
displays the matching sequences 200 entries at a time.  Scroll 
through the list to find the sequence(s) you want.  Click on the Next 
200 Matches or Previous 200 Matches button to move through the 
sequences. 

c. Select one or more sequences.  Choose from the following: 

• Select one sequence by pointing to it and clicking the left mouse button. 

• Select adjacent sequences by pressing the left mouse button and 
dragging the mouse to include all the sequences you want. 

• Select adjacent sequences by shift-clicking.  Point to the first sequence 
and click the left mouse button.  Then, point to the last adjacent 
sequence you want to select, press <Shift> and click the left mouse 
button.  All the sequences between the two clicks are highlighted. 

• Select non-adjacent sequences by control-clicking.  To do so, press 
<Ctrl> and click the left mouse button on each sequence you want. 

4. Click Add to add the selected vector sequence(s) to the project. 

5. When you finish with the Database Browser window, click the Close 
button. 

Finding and masking vector sequence 

Once you have added vector sequences to your project, you must scan your 
project to find and mask fragments containing vector.  Masked regions of 
fragments will then be hidden from subsequent alignments.  Since SeqMerge 
masks only unaligned, single-fragment contigs, you should always mask 
fragments before assembling. 
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SeqMerge only removes vector sequence found near the ends of the fragments 
(not vector sequence found internally) because vector sequence at the ends is 
likely to be the result of sequencing across the cloning site. By default, if 
SeqMerge finds vector sequence within 12 base pairs of the end, it will mask the 
end (up to 12 bp) and all of the vector sequence.  If there are more than 12 non-
vector base pairs at the end of a sequence, SeqMerge considers the vector 
sequence to be internal, and does not mask it.  That is, if vector sequence is 
found 13 or more base pairs from the end, it is not masked.  For more 
information on the vector masking algorithm, see Appendix D, The SeqMerge 
Algorithms. 

To specify contaminating vector to mask in your fragment sequences: 

1. Select Vector... from the Project menu of the SeqMerge Project Manager.  
The SeqMerge Vector Manager appears. 

2.  Select the vector sequences in the SeqMerge Vector Manager:  
  Tip: If you have nested vector sequences, you might want to scan the 

project more than once to ensure that you masked all vector sequence.  That 
is, you should scan the project at least as many times as you have levels of 
nested vectors because each scan only masks the ends of the sequence.   

                        
• Select one vector by pointing to it and clicking the left mouse button. 
• Select all vectors by clicking Select All. 
• Select adjacent vectors by pressing the left mouse button and dragging 

the mouse to include all the vectors you want. 
• Select adjacent vectors by shift-clicking.  Point to the first vector and 

click the left mouse button.  Then, point to the last adjacent vector you 
want to select, press <Shift> and click the left mouse button.  All the 
vectors between the two clicks are highlighted. 

• Select non-adjacent vectors by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each vector you want. 

3.  Specify the sequence alignment parameters to use to locate the vector 
sequence.   
SeqMerge determines all possible alignments between the vector and each 
fragment sequence using the algorithm described in Appendix C, The 
SeqMerge Algorithms.  SeqMerge masks any alignment that 1) starts within 
12 base pairs of the end of a fragment, and 2) meets the following criteria: 
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Word Size: 
The number of identical bases in each short block (word) SeqMerge uses to 
find similarity between a vector sequence and each fragment.  SeqMerge 
looks for word matches between the vector and each fragment, and creates 
initial alignments from them.  (During the initial alignment to determine 
similarity, SeqMerge places gaps between blocks, but not within blocks.)  
Specify the minimum length for each short block of identities by adjusting 
the word size.  You can specify any word size from 1 to 30; the default is 7. 

Stringency: 
The fraction of words between vector and fragment should match in order, 
for a region of the fragment sequence to be identified as vector.  SeqMerge 
determines all possible distinct overlaps between the vector sequence and 
each fragment sequence.  Then, starting with the overlap containing the 
highest number of word matches, SeqMerge examines overlaps with 
progressively fewer word matches.  SeqMerge divides the number of 
matches along the overlap by the length of the overlap, and then determines 
if the fraction of matches found meets the Stringency threshold.  Once 
SeqMerge finds an overlap at an end that exceeds the threshold, it stops 
looking for another one and masks that end.  SeqMerge continues looking at 
overlaps with progressively fewer word matches until either both ends are 
masked or all possible overlaps have been checked.  You can specify any 
value from 0.51 to 1.0; the default stringency is 0.8. 

Minimum Overlap: 
The minimum number of bases that must overlap between vector and 
fragment sequence.  Overlaps shorter than this length are not considered for 
vector masking. You can specify any value greater than or equal to the 
Word Size; the default Minimum Overlap is 12.   

4.  Click Scan Project.  SeqMerge finds vector contamination at the ends of the 
fragments and masks them. 

Note:  If you have nested vector sequences, you may want to click Scan 
Project more than once. 

5. Click Close to close the SeqMerge Vector Manager.  The SeqMerge Project 
Manager displays a V in the Mask column of all fragments that have had 
their vector sequence masked.  When you assemble these fragments into 
larger contigs, the contigs are also denoted with a V in the Mask column.   

When you view the fragment sequences in the SeqMerge Contig Editor, 
masked vector sequence appears gold.  For more information, see Chapter 
4, Working in the Contig Editor. 
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Note:  If a fragment contains only vector sequence, SeqMerge creates a 
completely masked contig with zero length because masked sequence does 
not contribute to contig length.  While this zero length contig provides a 
record of the original fragment, it is not considered for any alignment or 
consensus sequence determination.  You may eventually want to remove it 
from your project.  See “Removing Fragment Sequences From a Project” 
later in this chapter. 

Locating contigs containing masked vector sequence 

You can tell which contigs contain masked vector sequence in the following 
ways: 

• SeqMerge displays a “V” in the Mask column of the SeqMerge Project 
Manager 

• SeqMerge displays a “V” in front of each masked fragment in the Contig 
Contents Viewer. 

• SeqMerge displays masked vector bases in the color gold in the SeqMerge 
Contig Editor.  For more information on the SeqMerge Contig Editor, see 
Chapter 6, Working in the Contig Editor. 

Removing vector sequences from a sequencing project 

SeqMerge masks vector sequences in a project only when you explicitly mask 
them as described previously in this chapter.  Therefore, you can add several of 
your most popular vectors to every project and mask just the appropriate 
sequence in each project.  However, if you add a vector sequence to the project 
by mistake, you can remove it at any time. 

To remove vector sequences from a project: 

1. Select the vector sequences in the SeqMerge Vector Manager:  
• Select one vector by pointing to it and clicking the left mouse button. 
• Select all vectors by clicking Select All. 
• Select adjacent vectors by pressing the left mouse button and dragging 

the mouse to include all the vectors you want. 
• Select adjacent vectors by shift-clicking.  Point to the first vector and 

click the left mouse button.  Then, point to the last adjacent vector you 
want to select, press <Shift> and click the left mouse button.  All the 
vectors between the two clicks are highlighted. 

• Select non-adjacent vectors by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each vector you want. 

2. Click Delete. 

3. Click OK to confirm. 
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5. Assembling Fragments 

Overview 

SeqMerge assembles single- or multiple-fragment contigs into longer contigs of 
overlapping fragments by doing the following: 

Finding the first two contigs (initially, all contigs are single-fragment contigs) 
with the longest overlap and align them to create a longer contig. 

Finding the two contigs with the next longest overlap (one of these may be the 
just-assembled contig) and aligning them. 

Repeat the process of overlap determination and contig assembly until there are 
no remaining overlaps among the contigs in the project.   

The result of fragment assembly can be a single contig (if all contigs overlap to 
form a contiguous assembly) or several contigs (if no overlaps are found among 
remaining contigs).  

This chapter describes how to use SeqMerge to assemble your fragments into 
contigs.  It also provides an example sequencing project, which demonstrates the 
steps and considerations you might see in a typical sequencing project.  

Assembling contigs 

SeqMerge assembles two or more contigs into one contig as long as there is 
“sufficient overlap” between them.  You can specify what sufficient overlap is 
by altering the assembly parameters. 

To assemble overlapping fragments into contigs: 

1. Select Assemble... from the Assemble menu of the SeqMerge Project 
Manager Window.  The Assemble Project dialog box appears. 
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2.  Choose from the following: 
• If you want to assemble all of the contigs in your project, click the 

Assemble All Contigs button. 
• If you want to assemble only contigs you have selected, click the 

Assemble Selected Contigs button.  To select one or more contigs in the 
Project Manager: 

• Select one contig by pointing to it and clicking the left mouse button. 
• Select adjacent contigs by pressing the left mouse button and dragging 

the mouse to include all the contigs you want. 
• Select adjacent contigs by shift-clicking.  Point to the first contig and 

click the left mouse button.  Then, point to the last adjacent contig you 
want to select, press <Shift> and click the left mouse button.  All the 
contigs between the two clicks are highlighted. 

• Select non-adjacent contigs by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each contig you want. 

Specify a value for each of the following parameters by typing the value in the 
corresponding text box: 

Word Size   

The number of identical bases in each short block (word) SeqMerge uses to find 
overlaps in fragments.   SeqMerge looks for word matches at the ends of 
fragments, and then creates alignments from them.  (When finding overlaps, 
SeqMerge will create gaps between words, but not within words.)  Specify the 
minimum length of each short block of identities by adjusting the word size.  
You can specify a word size from 1 to 30.  The default is 7. 

Note:  Increasing the word size causes SeqMerge to assemble more quickly and 
more selectively.  However, it also reduces the sensitivity, that is, SeqMerge 
may miss overlapping regions with higher levels of mismatch.  Conversely, 
decreasing the word size increases the assembly time and is more sensitive. 

Stringency   

The fraction of words at the ends of fragments (or contigs) that must match in 
order for SeqMerge to find overlap.  SeqMerge determines all possible distinct 
overlaps between the fragments.  Then, starting with the overlap containing the 
highest number of word matches, SeqMerge examines overlaps with 
progressively fewer word matches.  SeqMerge divides the number of matches 
along the overlap by the length of the overlap, and then determines if the 
fraction of matches found meets the Stringency threshold.  After finding all 
possible overlaps between a pair of fragments, SeqMerge counts the number of 
matches and the number of mismatches along the length of the overlap, and then 
determines if the fraction of matches found meets this threshold  You can 
specify a stringency value from 0.51 to 1.0.  The default is 0.8. 
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Note:  Reducing the stringency increases the sensitivity.  You will find more 
overlapping regions, and it won’t greatly increase assembly time. However, you 
may find false matches. 

Minimum Overlap 

It specifies the minimum number of bases that must overlap between two 
fragments (or contigs) for SeqMerge to determine them to overlap.  You can 
specify a value greater than or equal to word size.  The default is 14, twice the 
word size. 

Minimum Identity 

It specifies the minimum number of bases that must match identically in a region 
of overlap.  Every overlap in the contig must have at least one contiguous run of 
identical matches of at least this length.  Specify a value between the word size 
and the minimum overlap, inclusive.  The default is 14. 

Choose from the following to specify your type of assembly: 
• Click Assemble Current Contigs if you want to assemble from the 

previously-assembled fragments.  This option will assemble more 
quickly, but can miss overlaps between fragments that are already part 
of a multiple-fragment contig. 

• Click Assemble Edited Fragments if you want to reassemble the project 
completely, beginning with the edited fragments.  SeqMerge will 
disassemble all existing contigs and then assemble the edited fragments.  
(When SeqMerge disassembles edited fragments, it maintains all 
insertions, deletions, substitutions, and masks previously made to the 
fragments, but it does not maintain gap characters.) 

3.  Click OK to start assembling the fragments.  When the assembly 
completes, the new contigs appear in the SeqMerge Project Manager.  A 
plus sign (+) appears in front of contigs containing more than one fragment.  
Note:  Contigs are named after the first or left-most fragment in the contig. 

4.  Click on the plus sign to see a list of the fragments in the contig.   

Now you can view and edit your contigs from the SeqMerge Contig Editor For 
more information, see Chapter 6, Working in the Contig Editor.  

Building the contig consensus sequence 

When you assemble contigs, SeqMerge automatically creates a consensus 
sequence for each contig it assembles and displays it in the Contig Editor.  For 
more information on the algorithm that creates the consensus sequence, see 
“Building the Consensus Sequence,” in Chapter 6, Working in the Contig Editor. 
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Disassembling contigs 

You can manually disassemble all or selected contigs from the SeqMerge 
Project Manager.  You might want to do this, for example, if you’ve 
resequenced a repeat region and discovered an incorrect assembly, which your 
new fragment data may correct.  You can specify whether to keep or discard 
modifications you’ve made to the fragments in the contigs. 

To disassemble all contigs in a project: 

1. Select Disassemble from the Assemble menu.  The Disassemble Project 
dialog box appears. 

                     

2.  Click Disassemble All Contigs. 

3.  To ignore all previous modifications you’ve made to your fragments, click 
the Discard Edits; Revert to Archive box.  If you want to save your 
modifications, verify that this box is not selected. 

4.  Click OK. 

To disassemble selected contigs: 

1.  The SeqMerge Project Manager, select one or more contigs.  
• Select one contig by pointing to it and clicking the left mouse button. 
• Select adjacent contigs by pressing the left mouse button and dragging 

the mouse to include all the contigs you want. 
• Select adjacent contigs by shift-clicking.  Point to the first contig and 

click the left mouse button.  Then, point to the last adjacent contig you 
want to select, press <Shift> and click the left mouse button.  All the 
contigs between the two clicks are highlighted. 

• Select non-adjacent contigs by control-clicking.  To do so, press <Ctrl> 
and click the left mouse button on each contig you want. 

• From the Edit menu, choose Select All to highlight all contigs. 

2.  Select Disassemble from the Assemble menu of the SeqMerge Project 
Manager.  The Disassemble Project dialog box appears. 

3.  Click Disassemble Selected Contigs. 

4.  To ignore all previous modifications made to your fragments, click the 
Discard Edits; Revert to Archive box.  If you want to save your 
modifications, verify that this box is not selected. 
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5.  Click OK.   
Disassembling one fragment 

Occasionally, you might want to remove just one fragment from a contig. For 
example, if you discover a fragment from a bad trace file. 

• To disassemble one fragment from a contig: 

• Select the fragment you want to remove. 

• Select the Reject option from the Edit menu of the SeqMerge Contig Editor. 
The confirm Rejection dialog box appears. 

For more information, see “Removing a Fragment” in Chapter 6, Working in the 
Contig Editor. 

Considering assembly strategies  

You may assemble and disassemble contigs several times while working on a 
sequencing project.  Depending on where you are in the assembly process, your 
approach to creating contigs in SeqMerge will differ.   

The “Example Project Assembly” section below describes the steps you might 
take in a typical assembly project.  Each step describes the current status of the 
project, suggests an approach to solve the problem at that step, and discusses the 
rationale behind the approach. 

Example project assembly 

The flowchart below represents a typical process for assembling fragments in a 
sequencing project.  Each major step is labeled.  You can obtain more 
information on each step from the following sections of this manual: 

Step A.  See “Creating a Sequencing Project”, in Chapter 3, Working in the      
Project Manager. 
Step B.  See “Adding Sequences to a Project”, in Chapter 3, Working in the 
Project Manager.   
Step C.  See Chapter 4, Masking Vector Sequences. 
Step D.  See Chapter 5, Assembling Fragments. 
Step E.  See Chapter 6, Working in the Contig Editor, and Chapter 7, Working 
in the Trace Viewer. 
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Example Project Assembly:  This flowchart represents the steps you take to 
assemble fragments in a typical sequencing project.  Note that the majority of 
your hands-on time will likely be spent at step E. 

Example stages in contig assembly 

You can use SeqMerge to assemble many fragments automatically by simply 
following the procedure outlined in steps A-D of the Example Assembly Project 
figure on the previous page.   
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However, you will likely encounter fragment data that doesn’t automatically 
assemble into a single contig using the SeqMerge defaults.   For example, you 
might have ambiguous fragment ends that you need to hand edit after viewing 
their trace data.  The following stages provide example situations you might 
encounter while trying to assemble fragments in SeqMerge.  The stages below 
define the problem, suggest actions you can take to solve the problem, and 
explain the rationale for the suggested action. 

Stage 1 

Problem: 

You have just created a new project (A), added your fragments to it (B), scanned 
your fragments for vector contamination (C), and assembled using default 
assembly parameters.  You have contigs you think should merge, but the initial 
assembly did not find sufficient overlap to align them.  

Suggested Action: 

Assemble all or a selected subset of the contigs again with the default 
parameters.   

Rationale: 

You use the default parameters for your initial alignments to rapidly assemble 
contigs from the fragments with strong overlap.  This general assembly 
determines the clear cut overlaps quickly and easily so you can devote more 
time to difficult assemblies.  However, why is it helpful to repeat the same 
assembly? 

Assembling contigs repeatedly with the same parameters can produce more 
complete results because of ambiguity in the consensus sequences that are used 
to determine overlaps.  During each round of alignment, SeqMerge chooses an 
unambiguous base for each ambiguous base in a contig’s consensus sequence.  
These unambiguous consensus sequences are used to determine overlaps in the 
subsequent round of the alignment.  SeqMerge may choose different 
unambiguous consensus bases with different rounds of assembly, resulting in 
different overlaps being recognized.  

Stage 2 

Problem: 

You have contigs that you think contain sufficient overlap, but they have not 
merged into one contig during the initial or subsequent runs of the Assemble 
program with default parameters.  You suspect that they are not merging due to 
high error levels in your sequencing data. 
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Suggested Action: 

Assemble all or a selected subset of the contigs using relaxed parameters.  
Repeat, if needed.  (See Stage 1.)  

Rationale: 

SeqMerge allows you to modify several parameters that affect the speed and 
sensitivity of contig assembly.  Follow these guidelines when you adjust 
assembly parameters: 

Relax the Stringency parameter to reduce the fraction of matching words needed 
for SeqMerge to find an overlap.  The poorer the quality of your data, the lower 
you may have to set the stringency, but the more carefully you’ll have to analyze 
the resulting alignments to avoid false overlaps. 

Note:  Reducing the stringency will not greatly increase the time required for the 
Assemble program to complete.  

If you believe that some overlaps may not contain even one block of 14 
contiguous sequence identities, reduce the Minimum Identity parameter.  Keep 
in mind that the requirement for at least one long block of identities (Minimum 
Identity) allows the Assemble program to exclude trivial overlaps from 
consideration.   

Note:  Reducing this requirement may lead to false contigs, and may 
significantly increase the time required for the Assemble program to complete. 

If you believe that fragments are so poorly determined that overlaps may not 
contain runs of at least seven identical bases in a row, you can reduce the Word 
Size parameter.   

Note:  Significantly reducing the word size can greatly increase the time 
required for the Assemble program and is not recommended. 

If you relax other parameters, you may want to increase the Minimum Overlap 
parameter to prevent false contig alignments.  Increasing this parameter 
increases the length required for an overlap.  That is, SeqMerge determines two 
contigs to overlap only if the stringency requirement is met for at least the length 
of the overlap specified by the Minimum Overlap parameter. 

Stage 3 

Problem: 

You still have multiple contigs that should assemble into one contig, but 
SeqMerge has not detected significant overlap to merge them, even with relaxed 
parameters. 
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Suggested Action: 

From the SeqMerge Contig Editor, examine the existing contigs and resolve 
inconsistencies.  For example, find selected columns where there are gaps or 
ambiguity symbols in the consensus sequence.  Then, using the sequence traces 
files (if you have access to them), correct sequence errors or, in the extreme 
case, throw out the fragments that obviously don’t belong in the contig 
alignment.  After you have corrected the sequence inconsistencies, disassemble 
the current contigs and re-assemble the edited, single-fragment contigs from 
scratch with the default parameters. 

Rationale: 

Simply resolving the inconsistencies and reassembling the edited single-
fragment contigs can greatly influence the assembly.  Remember that the 
Assemble program chooses the two contigs with the longest overlap, merges 
them, and then finds the next two contigs with the longest overlap.  Correcting 
errors in sequence data may improve overlap detection.   

Stage 4 

Situation: 

You have edited and masked the existing contigs, and assembled with less 
stringent parameters, but you still have two contigs you know should merge into 
one. 

Suggested Actions: 
1. Examine your contigs to see if you need to obtain more sequence data.  Are 

you simply missing data?  If you are, you can use the current contigs to 
design primers for further sequencing reactions. 
Once you add new sequence data to your project, you may want to 
disassemble and reassemble the entire project from scratch, or just work 
with selected contigs.  For example, if you have new sequencing data, but 
you have no idea where the data might be in relation to all of your other 
contigs, you might want to reassemble the whole project from scratch, 
keeping only your current sequence masks or edits.  Alternatively, if you 
know that a particular new fragment covers the range of sequence data that 
may overlap with existing contigs; you might align the new fragment with 
the existing contigs in your project.  For example, if you suspect that your 
new fragment overlaps with two current contigs so that they might align 
into one contig, you would select only three contigs for reassembly, the two 
existing contigs and the new fragment.  

2.  If you have complete coverage, but SeqMerge is not aligning one or more 
contigs, you can align manually. Choose from the following: 
• Overlay a contig onto a contig already loaded into the SeqMerge Contig 

Editor and then manually adjust the alignment. 
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• Merge multiple contigs by bringing more than one contig into the 
SeqMerge Contig Editor.   

For more information on both of these options, see “Forcing Contigs to 
Merge by Hand” in Chapter 6, Working in the SeqMerge Contig Editor. 

Note:  You should only perform these actions when you know your data 
well enough to be confident that the contig alignment represents the 
genomic sequence from which you obtained your fragments.   




