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Preface 
Welcome to SeqLab, the powerful graphical user interface to  
Accelrys GCG (GCG).  GCG provides over 150 programs for sequence analysis.  
These programs meet a wide range of analysis needs—from pattern, motif, and 
reference database searches to RNA secondary structure prediction; from 
restriction mapping to evolutionary analysis; from fragment assembly to 
sequence comparison.  Historically, GCG used a command-line interface.  With 
SeqLab’s graphical user interface, you can more easily perform the complex 
tasks of sequence editing, analysis, and annotation. 
 
This tutorial is a good starting point if you have little or no experience working 
with SeqLab.  It provides a brief introduction to and hands-on practice with the 
primary functions of SeqLab.  It is not intended to be comprehensive.  See the 
SeqLab Guide for a complete description of the interface or the Program Manual 
for a complete description of GCG programs.  
 
The lessons in this tutorial build upon one another; they are designed to be 
completed in the order they appear.  This tutorial will take about 2 hours to 
complete and will get you working with your own sequence data quickly. 

What do I need? 
To use this tutorial, you need: 
 
• An account to run GCG at a licensed site. 

• SeqLab installed at the licensed site. 

• A UNIX workstation running X Windows or a PC or Macintosh running X 
server software that has access to GCG and SeqLab. 

For more information on recommended X server software, see the Appendix. 
 
These tutorial lessons assume that you are familiar with working with dialog 
boxes and with using a mouse to select, click, and drag.  You will need to know 
little command-line syntax; however, some familiarity with your system’s UNIX 
operating system will be useful.  In addition, if you require an X server to 
display SeqLab on your PC or Macintosh, we recommend that you take time to 
learn how to use it before using SeqLab. 
 
If you have questions about any of these requirements, see your system manager 
or contact Accelrys’ Technical Support. 
E-mail:  support-us@accelrys.com, support-japan@accelrys.com, or  
support-eu@accelrys.com 

What will I learn? 
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This tutorial is designed as a quick overview of some of the primary functions of 
SeqLab.  In it you will cover the following: 

Part 1.  Introduction 

This section gets you started with working with SeqLab.  The first lesson of this 
section helps you set up your environment for this tutorial.  The second lesson 
introduces basic concepts you should become familiar with to understand and 
take advantage of SeqLab, including SeqLab’s two modes—one that helps you 
organize your sequences on a project-by-project basis, and another that aids 
editing and manipulation of sequences.  

Part 2.  Lessons 

Lesson 1:  Building Project Lists.  This lesson teaches you how to work with 
sequences in SeqLab, including loading personal sequences, working with 
database sequences, and entering a new sequence.  You’ll also become familiar 
with a key concept in SeqLab—list files. 
 
Lesson 2:  Running Programs.  While there are over 100 sequence analysis 
programs available through SeqLab, the basics of selecting sequences, running 
programs, and viewing output are the same.  Once you understand how to run 
one program within SeqLab, you understand the basics of running them all. 
 
Lesson 3:  Aligning Multiple Sequences.  This lesson and the next show you the 
power of SeqLab’s Editor mode, using multiple sequence alignment as an 
example.  This lesson helps you visualize the sequence data as an aid to fine-
tuning multiple sequence alignments. 
 
Lesson 4:  Working with Sequence Features.  Here you’ll learn more about 
viewing, adding, and manipulating sequence features within the Editor. 
 
Conclusion:  This short lesson shows you how to delete all the files used and 
created during the tutorial and gets your SeqLab environment ready for working 
with your “real” sequence data. 

Conventions 

• Text that you are instructed to enter using the keyboard is depicted in bold 
Courier New font, for example: Type tutorial.list in the text box and 
click OK. 

• All steps, where you are required to take some action, are bold.  
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Getting Started 

Before you begin 

Before you begin working with the tutorial exercises, there are a few steps you 
must take in preparation. 
 
It is a good idea to create a separate directory into which you can collect 
sequences used by and output created during the tutorial.  Then, when you are 
finished with the tutorial, you can simply delete the directory without getting it 
mixed in with any “real” project data. 
 
The exercises in this tutorial require a sample sequence file, which you can copy 
to your newly created tutorial directory. 
 
1.  If you are using a PC or Macintosh, start your X server software and open a 

terminal emulation window, such as an Xterm. 

The following steps should all be completed from this terminal emulation 
window. 

2.  Initialize the GCG environment. 

Initializing the GCG environment gives you access to GCG programs, the 
databases, and other information required for the package to run smoothly. 

% source <Installed directory Path>gcgstartup 
% gcg 
The gcgstartup command is how GCG is initialized at most sites.  If this 
command is not recognized at your site, see your system manager. 

3.  To create a tutorial working directory: 

a. Move to your home directory. 

cd 

b. Create a new tutorial subdirectory. 
mkdir tutorial 

4.  To copy the SeqLab Tutorial sample sequence to the new tutorial 
subdirectory: 

a. Move to the newly created tutorial subdirectory. 
cd tutorial 
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b. Copy the sample sequence tutorial.rsf to this directory. 
fetch+ tutorial.rsf 
 
Fetch+ copies GCG sequences or data files from the GCG database to your 
directory or displays them on your terminal screen. 
 
Fetch+ is a useful command that searches the GCG data directories for a 
specified file and copies it to your current directory. 

Note:  If you get an error message that this sequence cannot be found, 
contact your system manager. 

5.  Move back to your home directory. 

cd 

Starting SeqLab 

SeqLab is started by a simple command but it also has customized parameters 
you can use when you start it.  For example, SeqLab has two modes:  Editor and 
Main List.  By specifying the Mode parameter, you can indicate the mode in 
which to start SeqLab. 
1.  Start SeqLab: 

seqlab -mode=list & 

Let’s take a closer look at these commands: 

seqlab starts the SeqLab program. 

mode=list is an optional parameter useful mainly for running this tutorial.  
This parameter forces SeqLab to start in the Main List mode instead of 
Editor Mode. 

If you get an error message after typing the command, try initializing the 
package again.  For more information, see step 2 in “Before You Begin” 
earlier in this lesson.  If you still have troubles, see your system manager. 

After you issue the SeqLab command, the SeqLab Main Window appears, 
along with an About SeqLab welcome window.  Toward the bottom of this 
welcome window, note the telephone number and e-mail address for 
reaching Accelrys’ Technical Support. 
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2.  Click OK to close the welcome window and reveal the SeqLab Main 
Window. 

Setting your working directory 

 
Your working directory is the directory where SeqLab automatically writes 
output files.  Once you set this directory, it stays set from session to session until 
you change it.  No matter what directory you are in when you start SeqLab 
thereafter, your output files are written to the working directory last specified.  
This makes it easy to locate your output files. 
 
The first time you start SeqLab, it sets your working directory to the directory 
you are currently in.  For this tutorial, let’s set your working directory to the 
directory you created in the “Before You Begin” section of this lesson. 
1.  From the Options menu, choose Preferences....   

The User Preferences dialog box appears. 
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2.  If necessary, select General from the “Preferences:” option menu at the top of 
the dialog box. 

 
3.  Click the Working Dir... button. 

The Change Working Directory dialog box appears.  This dialog box lets 
you navigate to and select a directory. 

 
Note:  On some operating systems, the text labels displayed in this dialog 
box may differ.  For example, some operating systems display “Folders” 
instead of “Directories” and “Update” rather than “Filter.” 

4.  To select the tutorial directory: 

a. Select the “tutorial” directory in the “Directories” scroll list and click 
Filter. 

You may need to use the vertical scroll bars to scroll down in the list. 

b. Ensure that the “tutorial” directory name appears in the “Selection” text 
box and click OK. 

You return to the User Preferences dialog box, where the specification of 
your newly selected working directory appears to the right of the Working 
Dir... button. 

5.  Click OK in the User Preferences dialog box. 

SeqLab applies your changes to the working directory specification and 
closes the dialog box. 
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Working through this tutorial 

To help you work through this tutorial, we’ve designed a hypothetical situation: 
 
You’re a research-her working with Arabidopsis thaliana.  You recently 
sequenced a small piece of DNA of unknown function.  Your goal for this 
tutorial is to predict the function of the DNA and identify features of interest. 
 
To accomplish this goal, you mapped out five steps: 
1. Enter the unknown DNA sequence into SeqLab. 

2.  Find an open reading frame and translate this range to protein. 

3.  Search a protein database for sequences similar to this protein. 

4.  Align the unknown sequence with the protein sequences found in the 
database. 

5.  Examine the features noted in the database sequences and use them to 
predict regions in your unknown sequence that might have similar structure 
or function. 
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Introduction to the SeqLab Interface 
 
Overview 

What you need 

Before beginning this lesson, be sure you complete the Getting Started lesson. 
 
Note:  Since SeqLab allows you to change font settings, the SeqLab interface 
shown on your screen may look different than the interface shown in this 
tutorial.  To change font settings, choose Preferences... from the Options menu, 
and select Fonts from the “Preferences:” option menu, and select from the 
available settings.  

Becoming familiar  
with the SeqLab environment 

The SeqLab Main Window is your workbench from which you will analyze 
sequences.  SeqLab has two modes:  the Main List (which SeqLab is currently 
displaying) and the Editor. 
 
The Main List provides a good method of specifying the sequences with which 
you are working.  You can use this mode as a project management tool to 
identify related sequences. 
 
The Editor provides a number of ways for you to visualize your sequences.  
From this mode you can view, create, or edit sequences; create or edit an 
alignment; and work with sequence features.  You’ll learn more about both of 
these modes as you work through the tutorial. 
 
1. Take a few moments to familiarize yourself with elements in SeqLab’s Main 

List mode. 
Note that SeqLab will display the contents of the last list file you worked 
with.  The default list file is named working.list.  If this is the first time 
you’re working with SeqLab, working.list will be empty.  In the illustration 
below, we show example data to make the description more informative.           

Main list mode 
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2. Click on the “Mode:” option menu and select Editor.  

The SeqLab Main Window switches to Editor Mode. 

3. Take a few moments to familiarize yourself with the elements in SeqLab’s 
Editor Mode. 
Note that your Editor may be empty.  In the illustration below, we show 
example data to make the description more informative. 

4. When finished reviewing the Editor, click on the “Mode” option menu and 
select Main List. 
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Editor mode 

 

 Icon bar 

On the icon bar, you see icons, an option menu, and toggle buttons. 
 
Icons.  The following icons provide quick access to SeqLab features. 
 
Cuts entire sequences or regions within sequences and places them on the                                 
SeqLab clipboard. 
 
Copies entire sequences or regions within sequences and places them on the 
SeqLab clipboard. 
 
Pastes entire sequences or regions within sequences from the Clipboard.  This 
option is available only after using Cut or Copy.   
Lets you set protections for editing sequences, such as allowing ambiguous 
characters, gaps, standard IUB-IUPAC characters, or reversals. 
 
Displays sequence information, such as sequence name, accession number, 
description, authors, and reference, for the currently selected sequence. 
 
Groups selected sequences to make editing related sequences easier. 
Ungroups selected sequences. 
 
Insert/Check/Overstrike.  The keyboard option menu lets you choose between 
the following: 

Menu bar 
Pull-down menus list 
the commands you  
use to work with  
sequences. 

Mode 
The Mode: option  
menu button lets  
you move easily  
between the Main  
List and the Editor. 

Icon bar 
See description on the 
next page. 

Display 
This option menu lets 
you view sequence data 
as specially colored text 
or as a graphical display 
of features. 

Currently loaded list file
The List: specification 
displays the name of the 
list file currently loaded in 
the Main List.  When you 
save sequences in the 
Editor, they are saved in 
this list file. 

Status line
The status line helps you determine the 
location of the cursor within the loaded 
sequence data. 
If you look closely within the sequence 
data, you can see an “R" highlighted 
where the cursor is positioned.  The 
status line tells you that the cursor is at 
position 31 within the sequence 
hs70_maize, column 31 within the 
alignment.

Horizontal scale 
The horizontal scale allows 
you to change by factors of 
2 the amount of data  
displayed within this 
window--providing a more 
global view (1:2, 1:4, etc.)

Sequence names and data
SeqLab displays the name 
of each sequence you load 
into the Editor, as well as the 
sequence data. 
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• Insert.  Inserts or deletes characters within a sequence to the left of the 
cursor position. 

• Check.  Allows you to check that a sequence was entered correctly.  When 
you retype the sequence, SeqLab beeps if a mismatch occurs. 

• Overstrike.  Replaces or deletes characters at the cursor position. 

Wrap.  When you select the Wrap toggle button, SeqLab wraps sequence data, 
along with the ruler, so you don’t have to scroll horizontally to see the bases or 
residues in a sequence.  (Note that you may still need to scroll vertically.)  By 
default, the Wrap toggle button is not selected when you display the Editor. 

Invert.  When you select the Invert toggle button, SeqLab changes the 
characters to white or black on a colored background.  By default, the Invert 
toggle button is selected when you display the Editor. 

Online help 
Online help is available from the Help menu on the Main Window.   

 
 The Help menu provides help on the following topics: 

• On the Interface.  Displays following text box window. 
 

 
 

• On the GCG.  Displays following text box window. 
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• On SeqLab Version.  Displays the software version and copyright information. 
• On Database Versions.  Displays the latest versions of the databases installed at 

your site. 
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1. Building Project Lists 

Overview 

SeqLab provides an easy way to specify sequence files and database entries on a 
project-by-project basis.  You do this by adding entries to a list file, a concept 
you will be familiar with by the end of this lesson.  You will find that Main List 
mode serves as a handy project management tool, helping you specify related 
sequences. 
 
For this lesson you will create an Arabidopsis thaliana project list file.  You will 
learn how to add sequence file entries, as well as how to locate and work with 
public database entries.  You’ll also enter and save a short segment of DNA you 
recently sequenced from A. thaliana. 

What you need 

Before beginning this lesson, be sure you complete the Getting Started lesson. 

Introducing list files 

 
 

Note the “List:” text box toward the top of the SeqLab Main Window; it shows 
the currently loaded list file.  List files allow you to specify sequences located in 
different directories and databases.  For example, you can specify sequence 
entries from public or private databases, or sequence files from your personal 
directories.  However, instead of copying these sequences to your working 
directory, the list file notes the sequence’s location.  For instance, instead of 
copying sequences from the databases to your directory, you can simply point to 
them from within a list file.  Then, when you want to use the sequence, SeqLab 
finds the entry in the specified database. 
 
As you can see in the example below, a list file contains a list of sequence 
locations.  Think of list files as project management tools.  Each project you are 
working on can have its own separate list file that you can load into SeqLab’s 
Main List when you are ready to work on that project. 
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Personal sequences* 
Sequence files created with the  
GCG or other software programs. 
 

Creating a list file 

1. Click on the “Mode:” option menu and select Main List.   

 
2. To create a new list file: 

The first time you work with SeqLab, the program opens a new list file 
named “working.list” that you can use to begin organizing your project 
sequences.  For this tutorial, however, let’s create a new list file named 
tutorial.list. 

a. From the File menu, choose New List....   

 The New List File dialog box appears. 

b. Type tutorial.list in the text box. 

List File 

GenBank:ecoompaa 
GB_In:Dro5s 
uniprot_sprot:209l_hylla
 
/usr/users/smith/tutorial/g
amma.seq 
/usr/users/smith/tutorial/m
yseq.rsf{*} 
 
Private_Data:new.seq 
 
@/usr/users/smith/tutorial
/working.list 

Proprietary or  
private databases* 
Sequences from your own 
private database or from 
your organization’s 
proprietary database. 

 

GenBank 
Uniprot 
GenPept 

GCG  
Output files 
Sequence output files 
created by the GCG such as 
MSF,RSF,or other list files 
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c. Click OK. 

Note:  If you made changes to your previously loaded list, SeqLab 
prompts you to save any changes before opening up the new list file. 

The New List File dialog box disappears and the “List:” file 
specification on the Main Window displays the name of your newly 
created list file. 

Adding personal sequence files 

One of the first things you will want to do in SeqLab is add sequences.  For 
example, you can add sequence files from your directories. (See “Getting Your 
Sequences into SeqLab” in the Additional Tips section at the end of this lesson.) 
 
Let’s load an A. thaliana project sequence. 
1. From the File menu, choose Add Sequences From -> Sequence Files.... 

The Add Sequences dialog box appears. 

 
2. To change the filter SeqLab is using to display files: 

The Filter text box at the top of the dialog box helps you narrow the 
sequences displayed in the Files scroll list.  Your current filter should end 
with *.seq.  The * is a wildcard that means “anything or nothing”.  
Therefore, the *.seq filter will display all files in your working directory 
that end with .seq. 

a. Click the cursor in the “Filter” text box at the top of the dialog box and 
change *.seq to *.* . 

 The *.* filter tells SeqLab to display all files in your working directory. 
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b. Click the Filter button. 

 The “Files” scroll list displays all files in your working directory.  

 
3. In the “Files” scroll list, select tutorial.rsf. 

4. Click Add. 

5. Click Close. 

The dialog box disappears and the Main List displays your newly added 
sequence file. 

Adding database sequences 

Accelrys sells an optional database update service that includes GenBank, 
UNIPROT, GenPept, and other databases.  

1. From the File menu, choose Add Sequences From -> Databases....   

The SeqLab Database Browser appears. 
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The Database Browser lets you view individual entries within the databases 
available at your site.  More importantly, the Database Browser lets you add 
sequences to the list file you have loaded in the Main List.  Remember that 
instead of copying the sequences from the databases into your working 
directory the Database Browser adds the locations of the database sequences 
to your list file. 

To use the Database Browser effectively, you must know either the name or 
accession number of a database entry. 

2.  To add an entry from the Database Browser: 

A journal article of interest referred to a nucleic acid sequence A. thaliana 
by the accession number Z12136.  

a. Scroll down in the “Databases“ scroll list and select GenBank. 

GenBankPlus is a complete nucleic acid database that includes 
GenBank, and all EST, STS, and GSS sequences. 

b. In the “Database Specification:” text box, replace GenbankPlus:* 
with GenbankPlus:Z12136. 

c. Click Show Matching Entries. 

 The matching entry appears in the “Entries” list. 

 

d. Select the Z12136 entry in the “Entries” list. 

e. Click Add to Main Window. 

f.  Click Close. 

The dialog box disappears and the Main Window displays your newly 
added sequence files. 
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Saving a list file 

It is a good idea to save your work every so often in case there is a power 
shortage or you lose your connection to the network. 
 
From the File menu, choose Save List. 
 
SeqLab updates tutorial.list to include your newly added sequences. 

Entering a new sequence 

 
Now let’s enter a short A. thaliana sequence.  In Editor Mode, SeqLab allows 
you to enter new DNA, RNA, or protein sequences.  For this lesson, you’ll 
create a DNA sequence. 
1. Make sure nothing is selected in your Main List.  

If a sequence is selected, press and hold the <Ctrl> key and click your 
cursor on the selected sequence(s).  This control-clicking should deselect a 
selected sequence. 

2. Click on the “Mode:” option menu and select Editor. 

The Editor window appears. 
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3. To set Editor options: 

On the Editor window, there are several options you can set for displaying 
sequences and entering sequence information. 

a. Click the “Display:” option menu and select Residue Coloring. 
 
This color mode displays all similar residues with the same color (for 
example isoleucine, leucine, methionine, and valine are green). 

b.  Click the keyboard option menu and select Insert. 
 
This mode allows you to insert or delete sequence characters to the left 
of the cursor position. 

c. Note the Wrap toggle button. 
 
When you select the Wrap toggle button, SeqLab wraps sequence data, 
along with the ruler, so you don’t have to scroll horizontally to see the 
bases or residues in a sequence. 
 
Since you’ll be typing a short sequence, you don’t need to select the 
Wrap toggle button. 

d. Click the Invert toggle button. 
 
This mode displays sequence characters in white or black on a colored 
background. 

4. To create a new sequence: 

     a. From the File menu, choose New Sequence.... 

The New Sequence dialog box appears prompting you “What type of 
sequence?” 
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  b. Click DNA.  

The dialog box disappears and you’ll see a new sequence titled 
NewDNA in the Editor window, followed by a row of tildes (~).  The 
tildes act as a space holder until they are replaced by “real” sequence 
data. 

 
  

5. To rename the sequence: 

a. Make sure the sequence name NewDNA is selected. 

b. Click the Info icon. 

The Sequence Information dialog box appears. 

You can use this dialog box to rename a sequence, include a description 
of or comments about a sequence, or change the sequence attribute 
information, such as the sequence orientation or topology. 

c. In the “Name” text box, change NewDNA to unknown_dna. 

d. Click OK. 

  

The dialog box disappears and the new name appears in the Editor 
window. 
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6.  Click your cursor on the first tilde (~) of the sequence data and type the 
following: 

ATGGCGGACCAGCGCACCGACGAACAGA 

You can use lowercase or uppercase text—GCG programs do not 
differentiate between them.  If you make a mistake, just use the right and 
left arrow keys to move your cursor to the correct position, press <Delete> 
to remove the character to the left of the cursor, and type the correct 
character. 

Because you set the “Display:” option menu to Residue Coloring, SeqLab 
displays the sequence characters as multi-colored text, with each nucleotide 
represented by a different color.  

7.  To protect your sequence from accidental modification: 

After entering a new sequence, you may want to define what sequence 
modifications are allowed.  You can set sequence protections to allow 
unknown residues (N or X for nucleotides, or X for proteins), gaps, other 
text changes, or reversals/complementing. 

a. With your unknown_dna sequence name selected, click the Protect 
icon. 

             The Protections dialog box appears. 

 

When you create a new sequence, SeqLab allows all possible 
modifications.  Now that you have entered your sequence and made any 
necessary changes, you may want to protect it from further 
modifications. 

b. Deselect all of the options in this dialog box and click OK. 

 The protections are changed for the sequence and the dialog box closes. 

c. What happens if you try to modify a sequence you’ve protected?  Click 
in the sequence data and try to insert or delete characters.   
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SeqLab beeps and displays a “Cannot insert” message box or text in the 
status line at the bottom of the window.  Thus, your sequence is 
protected from modification.  To remove the “Cannot insert” message 
box, click OK. 
 
If you have trouble editing existing sequences, check the sequence 
protections as described earlier in this step. 

8.  To save your sequence: 

Because this new sequence is part of the current project you’ve been 
working on, you’ll want to add it to the list file loaded in the Main List. 

a. From the File menu, choose Save As.... 

 The Save As dialog box appears. 

b. Change the “File name:” specification to unknown.rsf.  

 

c. Click OK. 

SeqLab saves the sequence as an RSF (Rich Sequence Format) file and 
adds it to the list file loaded in the Main List. 

9.  Click on the “Mode:” option menu and select Main List.    

Note the new sequence file unknown.rsf that appears at the top of the list. 

10.  Double-click on the filename unknown.rsf. 

/user/users/smith/tutorial/unknown.rsf{*} 

/user/users/smith/tutorial/unknown.rsf {UNKNOWN_DNA} 

The entry expands to display the one sequence, unknown_dna, contained 
within the RSF file.  (You can expand RSF, list, and MSF files in this way 
to view a list of the sequences they contain.) 

RSF files can contain one or more sequences as well as descriptive 
information such as author, sequence weight, creation date, sequence 
description, and known sequence features.  RSF files get their name from 
the “rich” annotation of sequences features which they may contain.  For 
more information about RSF files, see “Rich Sequence Format (RSF) Files” 
in Appendix B, Types of Sequence Files in the SeqLab Guide. 
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11.  Collapse the expanded RSF file by double-clicking on the filename 
unknown.rsf again. 

12.  From the File menu, choose Save List. 

Summary 
In this lesson you learned how to: 

• Create a list file.  List files allow you to organize related sequence files from 
different directories and store their filename and location in one place.  For 
each project you are working on, you can build a separate list file. 

• Load personal sequences into the list file loaded in the Main List. 

• Load database sequences into the list file loaded in the Main List. 

• Set preferences in the Editor. 

• Enter a new sequence in the Editor. 

• Rename a sequence. 

• Protect a sequence from modification. 

• Save a file in the Editor. 

• Expand an RSF, list, or MSF file to display the sequence files it contains. 

Additional tips 

More on entering new sequences 

If you have a long sequence, entering the sequence data by hand may not be the 
most efficient way of creating a new sequence in SeqLab. 
 
You also can copy sequence data from another terminal window and paste it into 
SeqLab.  For more information, see the Tip in the “Moving, Deleting, or 
Copying Sequences” topic in Chapter 2 of the SeqLab Guide. 

 Importing sequences into SeqLab 

Many databases and software packages have their own sequence format.  To use 
sequences of a different format with SeqLab, try one of the following: 
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• From the Editor, you can directly import sequences in FastA, GenBank, 
Swissprot, Trembl, BSML, and GDE file formats.  For more information, see 
“Importing FastA, GDE, ABI, SCF, or GenBank Flat Files into the the 
Editor” in Chapter 2 of the SeqLab Guide. 

• If you have sequences in Staden, IntelliGenetics, EMBL, or PIR formats, 
SeqLab internally converts them to RSF format using SeqConv+.  To do so, 
Accelrys provides a number of reformatting programs.  For more 
information, see “Adding Items to a List” in Chapter 5 of the SeqLab Guide.  

• For other sequence file types (non-GCG sequence formats), you can use the 
Reformat program (from the Functions menu, select Importing/Exporting -> 
Reformat) to reformat the sequences into GCG format or SeqLab internally 
converts non-GCG sequence formats to RSF format using SeqConv+.  For 
more information, see the Reformat program or SeqConv+ in the Program 
Manual. 

Note:  If you have sequence files on your PC or Macintosh and want to use 
them with SeqLab, you must first transfer those files to the UNIX machine 
running SeqLab.  Ask your system manager about the best way  
to transfer files at your site. 

Using private or proprietary databases 

In addition to the public databases provided by Accelrys, you can also access 
sequences from proprietary or private databases if they are in GCG format.   
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2. Running Programs 
Overview 

GCG, upon which SeqLab is built, has over 150 programs you can use to do 
different types of sequence analysis.  In SeqLab, these programs are grouped by 
function (for example database searching, mapping, or fragment assembly) and 
appear under the Functions menu. 
 
A few of the most common functions, such as pattern finding, translating, 
reversing/complementing, and creating a consensus sequence, are available from 
the Edit menu within the Editor. 
 
This lesson teaches you how to select and run programs in SeqLab.   Although 
each program has a different analysis and a unique set of options for 
customizing that analysis, the basics of selecting input sequences, running a 
program, and viewing the output are the same. 
 
For this lesson you will use the tutorial.rsf sequence you copied to your directory 
in the Getting Started lesson.  This file contains a sequence that is a longer 
version of the unknown_dna sequence you entered in Lesson 2.  After 
translating the open reading frame for the tutorial.rsf sequence, you will then use 
the resulting protein sequence to search the database for similar sequences to 
help determine its function. 

 What you need 

Before beginning this lesson, be sure you complete the Getting Started and 
Building Project Lists lessons.  Also this lesson builds upon the previous lesson; 
if necessary, return to the previous lesson and work through its steps and 
concepts. 

Setting output preferences 

There are a number of preferences you can set for running programs and 
working with output files. 
1. From the Options menu, choose Preferences.... 

The User Preferences dialog box appears. 

2. Select General from the “Preferences:” option menu at the top of the dialog 
box. 
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3. Set the “After I push the ‘Run’ button” option to “Close the window”. 

This preference automatically closes a program window after a program 
begins to run. 

4. Click Apply. 

5. Select Output from the “Preferences:” option menu at the top of the dialog 
box.   

 
6. Select “Automatically display new output.” 

This option tells SeqLab to automatically display output when a program 
finishes running. 

7. Click OK. 

SeqLab applies the changes and closes the dialog box. 

Finding open reading frames 

Before translating the unknown sequence, you should determine which reading 
frame is correct for this gene.  The Frames program will show you open reading 
frames. 
For this section of the lesson, you will use the sequence you loaded in Lesson 1, 
tutorial.rsf.  This file contains a sequence which is a longer version of the 
unknown_dna sequence you entered in Lesson 2. 
1. From Main List mode, select tutorial.rsf. 

2. Click on the “Mode:” option menu and select Editor. 

SeqLab switches to Editor mode and loads the file you selected from the 
Main List. 
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3.  Select the sequence name unknown_dna. 

4.  From the Functions menu, choose Gene Finding and Pattern Recognition -> 
Frames.... 

The Frames program window appears. 

All program windows have a similar layout, and once you become familiar 
with the way you interact with one program, you know the basics of 
interacting with them all.  Take a few moments to familiarize yourself with 
the main components of a SeqLab program window. 
 

These buttons allow you 
to select optional 
parameters, save or 
restore your customized 
parameter settings, or 
use default parameter 
settings.

Displays the input 
sequence(s) you chose 
from the Main List or from 
the Editor before you 
selected this program 
from the Functions menu.  
You cannot edit the text 
in this this box.

Program summary
Input sequence(s)

Required parameters

Required parameters are 
those you must set for the 
program to run.  Default 
values are provided.

Parameter buttons

Command-line equivalent
Action buttons

A summary appears at 
the top of each program 
window describing the 
primary function of the 
program you selected.

This text box may be useful to 
those familiar with the command- 
line version of the Package.  You 
cannot edit the text in this box 
directly, but it is useful for 
verifying that the correct 
parameters have been set.

These buttons tell the 
program what action to 
take: close the window, 
run the program, or 
provide help.

 
5. Check that the Frames program window lists unknown_dna in the input 

sequence(s) area. 

If it doesn’t, click Close to exit the Frames window and select the correct 
sequence.  Then from the Windows menu, choose Frames.  Once you’ve 
opened a program window, SeqLab remembers it for the rest of your current 
session and adds it to the Windows menu. 

6. Verify that the required parameters provide the correct information. 
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The Frames program lists only one required parameter—a translation table 
for which it provides the default file translate.txt.  Translation tables define 
the relationship between codons and amino acids as well as identify start 
and stop codons. 

A. thaliana uses the default translation table translate.txt, so there is no need 
to change this parameter. 

7. To check out the optional parameters available for Frames: 

a. Click Options. 

The Frames Options dialog box appears. 

 

  This dialog box lists the parameters you can use to customize the 
program.  Take a moment to look through these optional parameters.  
For this tutorial, however, you’ll just perform the standard analysis, so 
there is no need to change the parameters. 

 b. Click Close. 

8.  To choose how you will run the program: 

 a. Click on the “How:” option menu at the bottom of the window. 

The “How:” option menu displays the methods by which you can 
run each program.  These options are set up by your system 
manager, so your menu may look differently than the example at 
the left. 

 b. Select Background Job. 
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This option will run the program immediately.  The other available options 
allow you to run the program at a later time in batch. Note that the method 
you choose for running this program becomes the default method used for 
running subsequent programs.  The chosen method stays in effect until you 
change it. 

9.  Click Run to start the program. 

The Frames program window closes.  Frames is a fast running program, so 
you should not have to wait long for the program to finish running.  The 
Frames output automatically displays along with the SeqLab Output 
Manager window. 

10.  To determine the largest open reading frame: 

 

The Frames output shows the open reading frames as blue rectangles for all 
six translation frames. 

a. Examine the output and note that the largest open reading is in the first 
frame. 

b. Click Close. 

  SeqLab closes the Frames output window.  Behind the Frames output 
you will find the SeqLab Output Manager. 
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The Output Manager keeps track of the output files created in your current 
session with SeqLab.  From this window, you can add, rename, print, or 
delete output files.  The Output Manager also lets you add sequence and list 
files directly to the Main List or to the Editor.    You should see the Frames 
output file just created, unknown_dna_#.figure, in the Output Manager 
Scroll list.  The # in unknown_dna_#.figure is a number SeqLab assigns 
based on the number of times you have run programs.  If this is the first 
program you have run in SeqLab, the output file will be named 
unknown_dna_1.figure. 

11. Click Close in the Output Manager. 

SeqLab closes the window. 

Translating 

Now that you know the correct open reading frame, you can translate the DNA 
sequence to protein.  To do so, you will use the Translate function, which is an 
option within the Editor’s Edit menu. 

1. In the Editor, select the sequence name unknown_dna. 

2.  From the Edit menu, choose Translate.... 

 

The Translate dialog box appears. 

3.  Set the appropriate translation parameters and run the program. 

In the previous exercise you determined that the first reading frame is the 
largest.  Set the translation parameters to the following: 
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“Reading Frame:“  First 

“Genetic Code:” 01 Standard 

“Translate to:”  One-Letter Codes 

“Align Translation”  deselected 

4. Click OK. 

The translated sequence appears below the original DNA sequence.  The 
new sequence is named unknown_dna_frame1. 

5. To rename the translated sequence: 

 a. Select the sequence name unknown_dna_frame1. 

 b. Click the Info icon. 

      The Sequence Information dialog box appears. 

 c.  In the “Name:” text box, replace unknown_dna_frame1 with      
unknown_protein. 

 d. Click OK. 

The Sequence Information dialog box disappears and the Editor 
displays two sequences. 

 
6. To save your changes: 

 a. From the File menu, choose Save As.... 

  The Save As dialog box appears. 

 b. In the “File name:” text box, type unknown.rsf. 

 c. Click OK. 

  SeqLab displays a prompt notifying you that a file by that name already 
exists. 
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      The unknown_dna sequence you entered in Lesson 1 was saved in a file 
named unknown.rsf.  You now want to save a new version of 
unknown.rsf with two sequences, unknown_dna and unknown_protein. 

7. Click Overwrite. 

Both sequences are saved in the file unknown.rsf and are added to the list 
file currently loaded in the Main List. 

Searching the databases for related sequences 

Now that you’ve translated the unknown DNA, use the resulting protein to 
search the PIR database and find similar sequences. 

1. Click on the “Mode:” option menu and select Main List. 

2. In Main List mode, double-click on the filename unknown.rsf. 

      /usr/users/smith/tutorial/unknown.rsf {*} 

      /usr/users/smith/tutorial/unknown.rsf {UNKNOWN_DNA} 

      /usr/users/smith/tutorial/unknown.rsf {UNKNOWN_PROTEIN} 

The entry expands into the two sequences saved in that file:  unknown_dna 
and unknown_protein.   

3.  With the file expanded, select unknown_protein. 

4.  From the Functions menu, choose Database Sequence Searching -> 
FastA.... 

The FastA program window appears.  Using the method of Pearson and 
Lipman1, FastA searches a selected database for entries that are similar to 
your query sequence. 

5. Check that the required parameters match those shown in the screen below. 
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If they are different, click the GCG Defaults button.  This button changes all 
parameters except the input sequence to the default settings. 

Confirm that the “How:” option menu at the bottom of the program window 
is set to Background Job. 

6.  Click Run. 

The FastA program window disappears and the program begins to run. 

7.  To check on the status of your FastA job: 

The FastA program may take a few minutes to complete.  To check on the 
status of a running program, use the Job Manager. 

From the Windows menu, choose Job Manager. 

The Job Manager window appears. 

 

The Job Manager is useful for monitoring the progress of a job, stopping a 
job, or troubleshooting job errors.  You’ll notice that the Job Manager lists 
all jobs you’ve run during your current session, even those that have 
completed (for example Frames). 
 
In the upper area of the Job Manager window, select the FastA job. 
 
The lower area of the Job Manager displays the status of the job you 
selected. 

8. Click Close Job Mgr to exit the Job Manager.   
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9. When the FastA program completes, scroll through its output file to 
examine the results. 

You’ll notice that the FastA output file displays a list of the database entries 
that best match your query sequence as well as alignments of the regions of 
best overlap between the query and search sequences.  

10.  Click Close to close the FastA output window. 

11.  To rename the FastA outputs files and add it to the Main List: 

 a. In the Output Manager, select the unknown_protein_#.fasta file and click 
Save As.... 

  The Save As dialog box appears.   

 b. Type related_proteins.list in the text box. 

   

 c. Click Save. 

The FastA output file is renamed in the Output Manager as well as 
saved in your working directory. 

 d. Select the related_proteins.list file and click Add to Main List. 

  The file is added to the list file currently loaded in your Main List. 

 e. Click Close to exit the Output Manager. 

12.  In the Main List, double-click on the FastA output file, related_proteins.list. 

The list file expands to display the files it contains. 

13.  To examine the related sequences found in your FastA search: 

 a. In the Main List, double-click on the sequence PIR2:s22860. 

      The Sequence View dialog box appears, displaying information about 
this database sequence.  From this dialog box you can find out more 
about a sequence’s known attributes. 
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 b. Scroll down in the “Reference:” scroll list. 

As you read the known reference information, you’ll find that this is a 
calmodulin protein from rice. 

 c. Click Cancel to close the Sequence View dialog box. 

 d. View some of the other related sequences in the file 
related_proteins.list, repeating steps a - c above. 

 e. In the Main List, double-click on the filename related_proteins.list to 
collapse the file. 

By now you’ve found that most other sequences in this list, like sequence 
PIR2:s22860, are calmodulins also.  Based on the sequence similarity 
shown in the alignments in the FastA output file, you can reasonably 
assume that your unknown protein sequence is also a calmodulin. 

Summary 

  In this lesson you learned how to: 

• Set preferences for output display. 

• Rename an output file and add it to the list file loaded in the Main List. 

• Run simple analyses, such as translating, from the Editor. 

• Run sequence analysis programs from the Main List or the Editor. 

SeqLab is a very flexible program, allowing you to select sequences and run 
programs from the Main List or from the Editor.  From either mode, there are a 
number of common steps you will take to run a program in SeqLab: 
 
1. First, you choose one or more sequences on which you want to perform some 

analyses from the Main List or the Editor. 

2. Then you select the program you want to run from the Functions menu.  A 
program window appears, displaying your previously selected sequences as 
input. 
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3. On the program window you set the required program parameters.  If 
appropriate, you also can set optional parameters, which appear on a separate 
window you display by clicking the Options... button. 

4. When you have set all the required and optional parameters, run the program. 

5. To see the status of your job, you can open the Job Manager window.  This 
window displays each job you run in SeqLab and tells you if it is running, 
completed, waiting in a batch queue, or stopped because of an error. 

6. When the job is completed, you can switch to the Output Manager window, 
which lists the output files and lets you display or print them.  The Output 
Manager also lets you add sequence and list output files to the Main List or to 
the Editor. 

Additional tips 

Determining open reading frames 

In addition to the Frames program, there are a number of other programs in 
GCG that enable you to determine open reading frames as a function of their 
analyses.  Those programs include Map, CodonPreference, and TestCode. 

Searching the database for related sequences 

There are a number of programs in addition to the FastA program that search the 
databases for sequence similarity, including BLAST, FastX, FindPatterns, 
FrameSearch, ProfileSearch, SSearch, TFastA, and TFastX. 

For Command line users of GCG  

If you’re a command-line user of GCG and you’re making the leap to using 
SeqLab, there are a couple of features within SeqLab that you will find useful.  
One is the “Command Line:” text box (read only) that appears toward the 
bottom of each program window.  This text box displays the parameters you’ve 
selected—just as if you were running the program from the command line. 
 
Another feature you will find very useful is a pop-up help box for command-line 
parameter names.  Within a program window, or within a program’s optional 
parameters dialog box, point your mouse at a parameter and press and hold 
mouse the right button on a three-button mouse.  A pop-up help box appears, 
displaying the command-line parameter name. 
 
 
 

 


